Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1356018 - dc's warning triangle "caused by config/image change" is not useful on web
Summary: dc's warning triangle "caused by config/image change" is not useful on web
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Deployments
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Jakub Hadvig
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-13 09:38 UTC by Xingxing Xia
Modified: 2016-09-27 09:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-27 09:40:07 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1933 normal SHIPPED_LIVE Red Hat OpenShift Container Platform 3.3 Release Advisory 2016-09-27 13:24:36 UTC

Description Xingxing Xia 2016-07-13 09:38:59 UTC
Description of problem:
For a deployment triggered by config change or image change, there are always a yellow triangle near each dc on dc page. Hover mouse on the angle, it shows "caused by a config change", "caused by an image change". This display is ugly. Because, after all, the causes are normal. Triangle should display only when message is abnormal 


Version-Release number of selected component (if applicable):
oc v3.3.0.4
kubernetes v1.3.0+57fb9ac
features: Basic-Auth GSSAPI Kerberos SPNEGO

How reproducible:
Always

Steps to Reproduce:
1. Create a dc of config change:
oc run hello --image openshift/hello-openshift
2. Create a dc of image change:
oc new-app centos/ruby-22-centos7~https://github.com/openshift/ruby-ex.git 
3. Wait for the dc/hello, dc/ruby-ex deployed.
$ oc deploy hello
hello deployment #1 deployed 43 minutes ago - 1 pod

$ oc deploy ruby-ex
ruby-ex deployment #1 deployed 23 hours ago - 1 pod
4. Login to web console, go to dc page:
1> Click "Browse" --> "Deployments"
2> Click one dc, e.g. "hello", check the dc/hello page

Actual results:
4.
1> On dc page, near each dc, there is yellow triangle. Hover mouse on the triangle, it shows "caused by a config change", "caused by an image change". But there are already a "Trigger" column showing "Config change", "Image change"
2> On dc/hello page, there is also a yellow triangle near the dc name

Expected results:
4. Should remove the yellow triangle of such warning

Additional info:
In fact, this warning is from CLI:
oc get dc hello -o yaml:
...
status:
  availableReplicas: 1
  details:
    causes:
    - type: ConfigChange
    message: caused by a config change
...

But it is ugly and not useful to show this specific kind of message on web

Comment 1 openshift-github-bot 2016-07-18 13:31:26 UTC
Commit pushed to master at https://github.com/openshift/origin-web-console

https://github.com/openshift/origin-web-console/commit/6952a987bcf1b657befc8b7e0333eeccc00b3d95
Bug 1356018: dc's warning triangle 'caused by config/image change' is not useful on web

Comment 2 Xingxing Xia 2016-07-20 02:30:56 UTC
Checked latest puddle, it does not yet include the fix. Will check next puddle when available.

Comment 3 Xingxing Xia 2016-07-20 03:02:18 UTC
First tested with latest Origin, the issue is fixed. The warning triangle now is not shown in dc list page and specific dc page.

Comment 4 Xingxing Xia 2016-07-22 05:13:32 UTC
Tested against:
$ openshift version
openshift v3.3.0.8
kubernetes v1.3.0+57fb9ac
etcd 2.3.0+git

Like comment 3, fixed.

Comment 6 errata-xmlrpc 2016-09-27 09:40:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1933


Note You need to log in before you can comment on or make changes to this bug.