Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355979 - incorrect PIDFile in the service file
Summary: incorrect PIDFile in the service file
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: mongodb
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z9
: 10.0 (Newton)
Assignee: Flavio Percoco
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-13 08:04 UTC by Attila Fazekas
Modified: 2018-09-17 17:01 UTC (History)
12 users (show)

Fixed In Version: mongodb-2.6.11-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-17 16:59:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2671 None None None 2018-09-17 17:00:47 UTC

Description Attila Fazekas 2016-07-13 08:04:26 UTC
Description of problem:
$ grep -i Pid /usr/lib/systemd/system/mongod.service 
PIDFile=${PIDFILE-/var/run/mongodb/mongod.pid}

$ sudo journalctl -u mongod
-- Logs begin at Wed 2016-07-13 03:16:55 EDT, end at Wed 2016-07-13 03:55:31 EDT. --
Jul 13 03:32:10 aio-1 systemd[1]: [/usr/lib/systemd/system/mongod.service:9] Not an absolute path, ignoring: ${PIDFILE-/var/run/mongodb/mongod.pid}
Jul 13 03:32:10 aio-1 systemd[1]: Starting High-performance, schema-free document-oriented database...
Jul 13 03:32:10 aio-1 mongod[3510]: about to fork child process, waiting until server is ready for connections.
Jul 13 03:32:10 aio-1 mongod[3510]: forked process: 3512
Jul 13 03:32:10 aio-1 systemd[1]: Started High-performance, schema-free document-oriented database.
Jul 13 03:32:10 aio-1 systemd[1]: [/usr/lib/systemd/system/mongod.service:9] Not an absolute path, ignoring: ${PIDFILE-/var/run/mongodb/mongod.pid}
Jul 13 03:32:12 aio-1 systemd[1]: [/usr/lib/systemd/system/mongod.service:9] Not an absolute path, ignoring: ${PIDFILE-/var/run/mongodb/mongod.pid}
Jul 13 03:32:21 aio-1 systemd[1]: [/usr/lib/systemd/system/mongod.service:9] Not an absolute path, ignoring: ${PIDFILE-/var/run/mongodb/mongod.pid}
Jul 13 03:32:21 aio-1 systemd[1]: [/usr/lib/systemd/system/mongod.service:9] Not an absolute path, ignoring: ${PIDFILE-/var/run/mongodb/mongod.pid}
...

Jul 13 04:00:27 aio-1.localdomain systemd[1]: Stopped High-performance, schema-free document-oriented database.
Jul 13 04:00:27 aio-1.localdomain systemd[1]: [/usr/lib/systemd/system/mongod.service:9] Not an absolute path, ignoring: ${PIDFILE-/var/run/mongodb/mongod.pid}
Jul 13 04:00:27 aio-1.localdomain systemd[1]: [/usr/lib/systemd/system/mongod.service:9] Not an absolute path, ignoring: ${PIDFILE-/var/run/mongodb/mongod.pid}
Jul 13 04:00:35 aio-1.localdomain systemd[1]: [/usr/lib/systemd/system/mongod.service:9] Not an absolute path, ignoring: ${PIDFILE-/var/run/mongodb/mongod.pid}
Jul 13 04:00:35 aio-1.localdomain systemd[1]: Starting High-performance, schema-free document-oriented database...

...

My journal is full with '[/usr/lib/systemd/system/mongod.service:9] Not an absolute path, ignoring: ${PIDFILE-/var/run/mongodb/mongod.pid}' messages.


Version-Release number of selected component (if applicable):
puppet-mongodb-0.14.0-0.20160630151558.9bcfd17.el7ost.noarch
python-pymongo-3.0.3-1.el7ost.x86_64
mongodb-server-2.6.11-1.el7ost.x86_64
systemd-libs-219-19.el7_2.11.x86_64
systemd-219-19.el7_2.11.x86_64
systemd-sysv-219-19.el7_2.11.x86_64


How reproducible:
Just stop and start the mongod service.

Expected results:
mongod start up without adding a red line to the journal.

Comment 2 Marek Skalický 2016-07-18 09:34:51 UTC
Same problem fixed in Fedora in bug 1231269

Comment 3 Flavio Percoco 2016-07-21 15:13:07 UTC
I fixed this in the spec file but the build step failed w/ an unrelated error. This should be fixed in the mongodb-2.6.11-2 version.

Package fix has been pushed.

Comment 5 shyam.biradar 2018-01-01 11:18:45 UTC
Hi,

I am facing the same issue. Is this fix pushed to redhat satellite? Can I get it using yum update on RHEL7.4? I tried it but it's saying no package marked for update. I still have mongodb 2.6.11.1

Comment 6 shyam.biradar 2018-01-01 11:20:37 UTC
This is a blocker for our product certification process. Please let us know the solution. Undercloud(RHOSP 10) installation is failing due to this issue.

Comment 7 Steve Linabery 2018-02-20 23:40:44 UTC
Flavio, did you ever get the build failure sorted? I see your latest commit on rhos-10.0-rhel-7 branch of mongodb downstrea, but mongodb-2.6.11-1.el7ost is latest build in rhos-10.0-rhel-7-candidate.

Also, why is target release 8.0?

Comment 18 Alex 2018-09-03 08:01:02 UTC
Hi there,

If this bug requires doc text for errata release, please set the 'Doc Type' and provide draft text according to the template in the 'Doc Text' field.

The documentation team will review, edit, and approve the text.

If this bug does not require doc text, please set the 'requires_doc_text' flag to -.

Thanks,
Alex

Comment 19 Martin Magr 2018-09-04 15:20:26 UTC
Patch is located in the package mentioned in "Fixed In" field.

Comment 21 errata-xmlrpc 2018-09-17 16:59:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2671


Note You need to log in before you can comment on or make changes to this bug.