Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355958 - pools cannot be used
Summary: pools cannot be used
Keywords:
Status: CLOSED DUPLICATE of bug 1350638
Alias: None
Product: Red Hat Storage Console
Classification: Red Hat
Component: Ceph
Version: 2
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 2
Assignee: Shubhendu Tripathi
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-13 07:09 UTC by Lubos Trilety
Modified: 2016-07-13 16:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-13 14:36:08 UTC


Attachments (Terms of Use)
rados output (deleted)
2016-07-13 07:09 UTC, Lubos Trilety
no flags Details
directory created by abort (deleted)
2016-07-13 07:52 UTC, Lubos Trilety
no flags Details

Description Lubos Trilety 2016-07-13 07:09:19 UTC
Created attachment 1179083 [details]
rados output

Description of problem:
Pools cannot be used as storage. For smaller files a new object is created, but it seems to be empty.
# echo "test file" > test.txt
# rados put -p <pool_name> new_object test.txt
# rados ls -p <pool_name>
new_object

# rados get -p <pool_name> new_object get_test.txt
# cat back_test.txt
# ls -l back_test.txt
-rw-r--r--. 1 root root 0 Jul 13 08:59 back_test.txt

For bigger files it crashes.
# dd if=/dev/zero of=testfile count=1000 bs=1M
# rados put -p <pool_name> new_object2 testfile
...
Aborted (core dumped)


Version-Release number of selected component (if applicable):
rhscon-ceph-0.0.31-1.el7scon.x86_64
rhscon-core-selinux-0.0.32-1.el7scon.noarch
rhscon-ui-0.0.46-1.el7scon.noarch
rhscon-core-0.0.32-1.el7scon.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Create cluster
2. Create some pool
3. Try to create some object in the pool

Actual results:
Smaller files are not saved correctly, bigger ones fails.

Expected results:
Files are saved correctly in the pool

Additional info:
There's cli output, which happens during add of bigger file, in attachment.

Comment 1 Lubos Trilety 2016-07-13 07:52:32 UTC
Created attachment 1179125 [details]
directory created by abort

Comment 2 Lubos Trilety 2016-07-13 08:38:46 UTC
ceph packages:
ceph-mon-10.2.2-5.el7cp.x86_64
ceph-common-10.2.2-5.el7cp.x86_64
ceph-base-10.2.2-5.el7cp.x86_64
ceph-selinux-10.2.2-5.el7cp.x86_64 
ceph-osd-10.2.2-5.el7cp.x86_64

Comment 3 Martin Bukatovic 2016-07-13 08:42:44 UTC
Since rados command line tool crashed here, could a ceph team review debug data
from abrt (attached to this BZ) to identify component responsible for the
problem?

(I'm raising needinfo from default contact of RADOS subcomponent of Ceph)

Comment 4 Samuel Just 2016-07-13 14:36:08 UTC
The problem with the small puts is probably a dup of https://bugzilla.redhat.com/show_bug.cgi?id=1350638 and has been fixed in the current packages.

*** This bug has been marked as a duplicate of bug 1350638 ***


Note You need to log in before you can comment on or make changes to this bug.