Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355943 - GRUB cannot find grubenv file
Summary: GRUB cannot find grubenv file
Keywords:
Status: CLOSED DUPLICATE of bug 1335533
Alias: None
Product: Fedora
Classification: Fedora
Component: grub2
Version: 26
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-13 06:15 UTC by W. Michael Petullo
Modified: 2017-04-20 07:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-20 07:27:08 UTC


Attachments (Terms of Use)

Description W. Michael Petullo 2016-07-13 06:15:18 UTC
Description of problem:
I was having trouble setting the default GRUB boot menu entry using grub2-set-default, so I read https://fedoraproject.org/wiki/GRUB_2. This document states:

"The above method fails to work on some F20 (and newer) systems due to a missing or improperly linked /boot/grub2/grubenv file. The /boot/grub2/grubenv is symbolic linked to /boot/efi/EFI/fedora/grubenv but /boot is not mounted at the time of booting. So grub2 does not have access to the environment variables. To fix this, change /boot/grub2/grubenv to point to ../efi/EFI/fedora/grubenv instead and your chosen default OS will boot without any problems."

I tried recreating the symbolic link as described, but GRUB still failed to boot the menu entry I wanted.

I *copied* grubenv from boot/efi/EFI/fedora/grubenv to /boot/grub2/grubenv instead, and that finally worked. However, I now have two copies of grubenv, and I am concerned some utility might cause them to become out of sync. (You cannot place the file at /boot/grub2/grubenv and the symbolic link at /boot/efi/EFI/fedora/grubenv because the efi filesystem is vfat.)

Is the documentation wrong?

Would it be possible to get rid of one of the copies of grubenv?

Version-Release number of selected component (if applicable):

grub2-efi-2.02-0.34.fc24.x86_64
grub2-efi-modules-2.02-0.34.fc24.x86_64
grub2-tools-2.02-0.34.fc24.x86_64

Comment 1 Robin Lee 2017-04-20 07:25:15 UTC
This issue persists in Fedora 26 Alpha.

Comment 2 Robin Lee 2017-04-20 07:27:08 UTC

*** This bug has been marked as a duplicate of bug 1335533 ***


Note You need to log in before you can comment on or make changes to this bug.