Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355920 - win10.x86_64 guest stay at starting windows screen when boot vm
Summary: win10.x86_64 guest stay at starting windows screen when boot vm
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.3
Hardware: x86_64
OS: Windows
high
high
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-13 01:59 UTC by Yanan Fu
Modified: 2017-02-09 02:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-09 02:57:31 UTC


Attachments (Terms of Use)
add screendump for this issue (deleted)
2016-07-13 02:03 UTC, Yanan Fu
no flags Details

Description Yanan Fu 2016-07-13 01:59:22 UTC
Description of problem:
Hit this issue in acceptance test with avocado.
Not only one case hit this isue,from the screendump,i find when boot/reboot guest, guest keep stay on the starting windows screen.
In my test the cpu model is: 
"-cpu 'Penryn',+kvm_pv_unhalt,hv_spinlocks=0x1fff,hv_vapic,hv_time"


Version-Release number of selected component (if applicable):
qemu-kvm:qemu-kvm-rhev-2.6.0-12.el7
kernel:3.10.0-462.el7.x86_64
virtio-win: virtio-win-1.8.0-4.iso

How reproducible:
Around 2/10

Steps to Reproduce:
1.boot/reboot win10.x86_64 guest
2.The VM keep stay at starting windows screen


Actual results:
The VM keep stay at starting windows screen

Expected results:
Guest should boot up successfully 

Additional info:
# cat /proc/cpuinfo 
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 23
model name	: Intel(R) Xeon(R) CPU           E5205  @ 1.86GHz
stepping	: 6
microcode	: 0x60f
cpu MHz		: 1861.827
cache size	: 6144 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 10
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm dca sse4_1 lahf_lm dtherm tpr_shadow vnmi flexpriority
bogomips	: 3723.65
clflush size	: 64
cache_alignment	: 64
address sizes	: 38 bits physical, 48 bits virtual
power management:


# lscpu 
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             2
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 23
Model name:            Intel(R) Xeon(R) CPU           E5205  @ 1.86GHz
Stepping:              6
CPU MHz:               1861.827
BogoMIPS:              3723.86
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              6144K
NUMA node0 CPU(s):     0-3


CLI:
/usr/libexec/qemu-kvm \
    -S  \
    -name 'avocado-vt-vm1'  \
    -sandbox off  \
    -machine pc  \
    -nodefaults  \
    -vga qxl \
    -device intel-hda,bus=pci.0,addr=03 \
    -device hda-duplex  \
    -chardev socket,id=qmp_id_qmpmonitor1,path=/var/tmp/avocado_phKV5l/monitor-qmpmonitor1-20160709-194814-GeCp9Ix7,server,nowait \
    -mon chardev=qmp_id_qmpmonitor1,mode=control  \
    -chardev socket,id=qmp_id_catch_monitor,path=/var/tmp/avocado_phKV5l/monitor-catch_monitor-20160709-194814-GeCp9Ix7,server,nowait \
    -mon chardev=qmp_id_catch_monitor,mode=control \
    -device pvpanic,ioport=0x505,id=idTX65gX  \
    -chardev socket,id=serial_id_serial0,path=/var/tmp/avocado_phKV5l/serial-serial0-20160709-194814-GeCp9Ix7,server,nowait \
    -device isa-serial,chardev=serial_id_serial0 \
    -device virtio-serial-pci,id=virtio_serial_pci0,bus=pci.0,addr=04,disable-legacy=off,disable-modern=on  \
    -chardev socket,id=devvs,path=/var/tmp/avocado_phKV5l/virtio_port-vs-20160709-194814-GeCp9Ix7,server,nowait \
    -device virtserialport,chardev=devvs,name=vs,id=vs,bus=virtio_serial_pci0.0  \
    -chardev socket,id=seabioslog_id_20160709-194814-GeCp9Ix7,path=/var/tmp/avocado_phKV5l/seabios-20160709-194814-GeCp9Ix7,server,nowait \
    -device isa-debugcon,chardev=seabioslog_id_20160709-194814-GeCp9Ix7,iobase=0x402 \
    -device nec-usb-xhci,id=usb1,bus=pci.0,addr=05 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=06,disable-legacy=off,disable-modern=on \
    -drive id=drive_image1,if=none,snapshot=off,aio=native,cache=none,format=qcow2,file=/usr/share/avocado/data/avocado-vt/images/win10-64-virtio-scsi.qcow2 \
    -device scsi-hd,id=image1,drive=drive_image1 \
    -drive id=drive_disk1,if=none,snapshot=off,aio=native,cache=none,format=qcow2,file=/usr/share/avocado/data/avocado-vt/images/storage.qcow2 \
    -device scsi-hd,id=disk1,drive=drive_disk1,serial=TARGET_DISK0 \
    -device virtio-net-pci,mac=9a:1d:1e:1f:20:21,id=idxs45AR,vectors=4,netdev=idzOBJvL,bus=pci.0,addr=07,disable-legacy=off,disable-modern=on  \
    -netdev tap,id=idzOBJvL,vhost=on,vhostfd=20,fd=19 \
    -m 16384  \
    -smp 2,maxcpus=2,cores=1,threads=1,sockets=2  \
    -cpu 'Penryn',+kvm_pv_unhalt,hv_spinlocks=0x1fff,hv_vapic,hv_time \
    -drive id=drive_cd1,if=none,snapshot=off,aio=native,cache=none,media=cdrom,file=/usr/share/avocado/data/avocado-vt/isos/windows/winutils.iso \
    -device ide-cd,id=cd1,drive=drive_cd1,bus=ide.0,unit=0 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -spice port=3000,password=123456,addr=0,tls-port=3200,x509-dir=/tmp/spice_x509d,tls-channel=main,tls-channel=inputs,image-compression=auto_glz,zlib-glz-wan-compression=auto,streaming-video=all,agent-mouse=on,playback-compression=on,ipv4  \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off,strict=off \
    -enable-kvm

Comment 1 Yanan Fu 2016-07-13 02:03:47 UTC
Created attachment 1179029 [details]
add screendump for this issue

Comment 2 Yanan Fu 2016-07-13 02:15:31 UTC
From comment 12 of bug 1339112,there exist one issue "Win7/2008 installer getting stuck on the Starting Windows screen",this is bug 1346982(from comment 17). And for rhev7 it should be bug 1346976.

May be, this is not a same issue, just add here as a conference.

Comment 4 Yanan Fu 2016-07-26 08:57:08 UTC
Now, this problem is very frequent in acceptance test.
In my test for latest rhev 7.2.z (qemu-kvm-rhev-2.3.0-31.el7_2.19), 8 cases failed as this problem.

The cpu module is :
"-cpu 'Penryn',+kvm_pv_unhalt,hv_spinlocks=0x1fff,hv_vapic,hv_time "

And the host is:
https://beaker.engineering.redhat.com/view/intel-5205-32-1.englab.nay.redhat.com#details

Comment 5 Vadim Rozenfeld 2016-07-27 02:40:10 UTC
(In reply to Yanan Fu from comment #4)
> Now, this problem is very frequent in acceptance test.
> In my test for latest rhev 7.2.z (qemu-kvm-rhev-2.3.0-31.el7_2.19), 8 cases
> failed as this problem.
> 
> The cpu module is :
> "-cpu 'Penryn',+kvm_pv_unhalt,hv_spinlocks=0x1fff,hv_vapic,hv_time "
> 
> And the host is:
> https://beaker.engineering.redhat.com/view/intel-5205-32-1.englab.nay.redhat.
> com#details

It probably sounds strange, but do you get the same result on different hosts or always on the same intel-5205-32-1.englab.nay.redhat.com ?
Another question if the issue is only reproducible with clu model
"-cpu 'Penryn',+kvm_pv_unhalt,hv_spinlocks=0x1fff,hv_vapic,hv_time "
or other compilations also lead to the same result?

Thanks,
Vadim.

Comment 6 Yanan Fu 2016-08-02 01:45:42 UTC
(In reply to Vadim Rozenfeld from comment #5)
> (In reply to Yanan Fu from comment #4)
> > Now, this problem is very frequent in acceptance test.
> > In my test for latest rhev 7.2.z (qemu-kvm-rhev-2.3.0-31.el7_2.19), 8 cases
> > failed as this problem.
> > 
> > The cpu module is :
> > "-cpu 'Penryn',+kvm_pv_unhalt,hv_spinlocks=0x1fff,hv_vapic,hv_time "
> > 
> > And the host is:
> > https://beaker.engineering.redhat.com/view/intel-5205-32-1.englab.nay.redhat.
> > com#details
> 
> It probably sounds strange, but do you get the same result on different
> hosts or always on the same intel-5205-32-1.englab.nay.redhat.com ?
> Another question if the issue is only reproducible with clu model
> "-cpu 'Penryn',+kvm_pv_unhalt,hv_spinlocks=0x1fff,hv_vapic,hv_time "
> or other compilations also lead to the same result?
> 
> Thanks,
> Vadim.

I have check the history when i hit this issue. hit this issue twice and it is with same host. I will try, if this issue can be reproduced with other host.

For cpu model, as this host has been return to beaker as used by other people now, i will update the result when it is available.

Comment 7 Vadim Rozenfeld 2017-01-12 08:27:00 UTC
Hi Yanan Fu,
Any update on this issue?

Thanks,
Vadim.

Comment 8 Yanan Fu 2017-01-12 11:18:20 UTC
(In reply to Vadim Rozenfeld from comment #7)
> Hi Yanan Fu,
> Any update on this issue?
> 
> Thanks,
> Vadim.

Hi Vadim,
During the last two months, can not hit this bz again.
So i think we can close it here.

Thanks 
Yanan Fu


Note You need to log in before you can comment on or make changes to this bug.