Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355916 - package requirement spec error on libField3D.so blocks upgrade
Summary: package requirement spec error on libField3D.so blocks upgrade
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: OpenImageIO
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Richard Shaw
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-13 00:50 UTC by Przemek Klosowski
Modified: 2016-07-15 01:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-15 01:31:05 UTC


Attachments (Terms of Use)

Description Przemek Klosowski 2016-07-13 00:50:05 UTC
Description of problem:
can't install nwe version


Version-Release number of selected component (if applicable):
OpenImageIO-1.5.24-1.fc23.x86_64 

How reproducible: every time


Steps to Reproduce:
1. dnf update.

Actual results:
Error: package OpenImageIO-1.5.24-1.fc23.x86_64 requires libField3D.so.1.6()(64bit), but none of the providers can be installed.

Expected results: error-free upgrade


Additional info:
This must be an incorrect package requirement specification, because libField3D.so.1.6 is installed:

dnf whatprovides libField3D.so.1.6
Field3D-1.6.1-7.fc23.i686 : Library for storing voxel data

rpm -q Field3D
Field3D-1.6.1-7.fc23.x86_64

rpm -ql Field3D
...
/usr/lib64/libField3D.so.1.6
/usr/lib64/libField3D.so.1.6.1
...

Comment 1 Przemek Klosowski 2016-07-15 01:31:05 UTC
appears to be resolved by Field3D-1.7.2-1.fc23.x86_64 which just appeared in F23


Note You need to log in before you can comment on or make changes to this bug.