Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355911 - No cross-linking of OpenShift node to OpenStack instance
Summary: No cross-linking of OpenShift node to OpenStack instance
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: cfme-future
Assignee: Ari Zellner
QA Contact: Jaroslav Henner
URL:
Whiteboard: container:smartstate:retest
Depends On:
Blocks: 1360384
TreeView+ depends on / blocked
 
Reported: 2016-07-12 23:51 UTC by nate stephany
Modified: 2017-09-20 17:46 UTC (History)
10 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1360384 (view as bug list)
Environment:
Last Closed: 2017-09-20 17:46:34 UTC
Category: ---
Cloudforms Team: Container Management


Attachments (Terms of Use)
cfme web ui view of ose node (deleted)
2016-07-12 23:51 UTC, nate stephany
no flags Details
Screenshot from 2017-03-16 14-32-05.png (deleted)
2017-03-16 12:37 UTC, Federico Simoncelli
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1371263 None None None Never

Internal Links: 1371263

Description nate stephany 2016-07-12 23:51:07 UTC
Created attachment 1179019 [details]
cfme web ui view of ose node

Description of problem:
With an OSE 3.2 deployment running on an OSP8 director environment, it does not appear that the OSE node cross-linking to the OpenStack instance is showing up in the UI.

Version-Release number of selected component (if applicable):
cfme 5.6.0.13
ose 3.2
osp 8 (director)

How reproducible:
100%

Steps to Reproduce:
1. add ose 3.2 provider following CloudForms docs
2. Wait for relationship discovery to happen
3. Browse to OSE node

Actual results:
A field under "Properties" that shows the Infrastructure Machine ID (which is the correct UUID of the OSP instance)

Expected results:
Something under relationships or properties that is clickable and takes you to the actual OSP instance in Compute > Clouds > Instances.

Additional info:

Comment 2 Federico Simoncelli 2016-07-21 14:43:41 UTC
Hi Nate, please work with Ari on this. I am sure we need much more information to work on this (logs, access to your environment, etc.).

Comment 3 nate stephany 2016-07-22 14:57:03 UTC
(In reply to Federico Simoncelli from comment #2)
> Hi Nate, please work with Ari on this. I am sure we need much more
> information to work on this (logs, access to your environment, etc.).

I've provided Ari the credentials to get into the environment to take a look.

Comment 4 Ari Zellner 2016-07-26 08:47:06 UTC
Upstream PR: https://github.com/ManageIQ/manageiq/pull/10036

Comment 6 Jaroslav Henner 2016-12-19 18:58:06 UTC
This is quite hard to test because one needs OpenStack with Load-Balancers deployed, otherwise docker fails to start.

Comment 7 Jaroslav Henner 2017-01-09 11:16:17 UTC
Version 5.7.0.17.20161219135818_725f92f 
I have added OpenStack as CloudProvider, OSPd as Infra provider, OpenShift as Container provider and I can't see the relationships. 

I can see  MachineId in the Node: openstack:///b02a1456-3ad1-46db-ae4d-43441c79daa7, but it is not clickable.

Comment 8 Federico Simoncelli 2017-01-09 11:22:25 UTC
(In reply to Jaroslav Henner from comment #7)
> Version 5.7.0.17.20161219135818_725f92f 
> I have added OpenStack as CloudProvider, OSPd as Infra provider, OpenShift
> as Container provider and I can't see the relationships. 
> 
> I can see  MachineId in the Node:
> openstack:///b02a1456-3ad1-46db-ae4d-43441c79daa7, but it is not clickable.

Ari please work with Jaroslav on his environment to identify the issue. Thanks.

Comment 9 Federico Simoncelli 2017-03-14 10:16:09 UTC
Jaroslav, if you still experience this issue in latest 5.7 please contact us ASAP and we can look at your environment.

Comment 10 Jaroslav Henner 2017-03-16 01:21:35 UTC
(In reply to Federico Simoncelli from comment #9)
> Jaroslav, if you still experience this issue in latest 5.7 please contact us
> ASAP and we can look at your environment.

If the OpenStack needs to be added as CloudProvider, I can give you the environment in 30minutes.

I still don't see the

Infrastructure Machine ID 	openstack:///372ad629-8407-4844-9095-2f6873046f69 

or anything else that would be clickable and led to the openstack instance.

Version 5.7.1.3.20170221135006_818f133

Comment 11 Federico Simoncelli 2017-03-16 08:44:55 UTC
(In reply to Jaroslav Henner from comment #10)
> (In reply to Federico Simoncelli from comment #9)
> > Jaroslav, if you still experience this issue in latest 5.7 please contact us
> > ASAP and we can look at your environment.
> 
> If the OpenStack needs to be added as CloudProvider, I can give you the
> environment in 30minutes.

I am going to contact you now on IRC to check if we can access your env. Thanks.

Comment 12 Federico Simoncelli 2017-03-16 12:37:00 UTC
Created attachment 1263660 [details]
Screenshot from 2017-03-16 14-32-05.png

Jaroslav in the env you provided the issue is not reproducing (Underlying Instance is visible and clickable in the Relationships).

Comment 13 Federico Simoncelli 2017-03-16 12:39:05 UTC
Jaroslav if it's not reproducible (let us know) I think we should close this.

Comment 14 Federico Simoncelli 2017-03-16 12:57:58 UTC
Apparently we had a PR here that fixed the issue so I am going to move this to ON_QA and you can VERIFY it.


Note You need to log in before you can comment on or make changes to this bug.