Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355899 - openstackclient quota command misbehaving when using project name
Summary: openstackclient quota command misbehaving when using project name
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-openstackclient
Version: 8.0 (Liberty)
Hardware: noarch
OS: Linux
low
low
Target Milestone: ---
: 8.0 (Liberty)
Assignee: Julie Pichon
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 21:34 UTC by Hanen Garcia
Modified: 2018-10-30 15:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 15:21:12 UTC


Attachments (Terms of Use)

Description Hanen Garcia 2016-07-12 21:34:51 UTC
Description of problem:
The openstack client's "quota" command doesn't behave properly when using project name instead of project id.

Version-Release number of selected component (if applicable):
python-openstackclient-1.7.2-1.el7ost.src.rpm

How reproducible:
Always

Steps to Reproduce:

1. Create a new project
openstack project create --description "Limited quota project" project-limited

+-------------+----------------------------------+
| Field       | Value                            |
+-------------+----------------------------------+
| description | Limited quota project            |
| enabled     | True                             |
| id          | f5e9d7497e56430a9cae58c3a09daf51 |
| name        | project-limited                  |
+-------------+----------------------------------+

2. Assign quotas using project id
openstack quota set --cores 5 --ram 4096 f5e9d7497e56430a9cae58c3a09daf51

3. Verify assigned quotas using project name
openstack quota show project-limited

+----------------------+-----------------+
| Field                | Value           |
+----------------------+-----------------+
| backup_gigabytes     | 1000            |
| backups              | 10              |
| cores                | 20              |
| fixed-ips            | -1              |
| floating-ips         | 50              |
| gigabytes            | 1000            |
| gigabytes_iscsi      | -1              |
| health_monitor       | -1              |
| injected-file-size   | 10240           |
| injected-files       | 5               |
| injected-path-size   | 255             |
| instances            | 10              |
| key-pairs            | 100             |
| member               | -1              |
| network              | 10              |
| per_volume_gigabytes | -1              |
| pool                 | 10              |
| port                 | 50              |
| project              | project-limited |
| properties           | 128             |
| ram                  | 51200           |
| rbac_policy          | 10              |
| router               | 10              |
| secgroup-rules       | 100             |
| secgroups            | 10              |
| server_group_members | 10              |
| server_groups        | 10              |
| snapshots            | 10              |
| snapshots_iscsi      | -1              |
| subnet               | 10              |
| subnetpool           | -1              |
| vip                  | 10              |
| volumes              | 10              |
| volumes_iscsi        | -1              |
+----------------------+-----------------+

Actual results:
The command returns the default quota instead


Expected results:
The command should returns the project quota as it's the case when using the command with the project id instead of the project name.

openstack quota show f5e9d7497e56430a9cae58c3a09daf51

+----------------------+----------------------------------+
| Field                | Value                            |
+----------------------+----------------------------------+
| backup_gigabytes     | 1000                             |
| backups              | 10                               |
| cores                | 5                                |
| fixed-ips            | -1                               |
| floating-ips         | 50                               |
| gigabytes            | 1000                             |
| gigabytes_iscsi      | -1                               |
| health_monitor       | -1                               |
| injected-file-size   | 10240                            |
| injected-files       | 5                                |
| injected-path-size   | 255                              |
| instances            | 10                               |
| key-pairs            | 100                              |
| member               | -1                               |
| network              | 10                               |
| per_volume_gigabytes | -1                               |
| pool                 | 10                               |
| port                 | 50                               |
| project              | f5e9d7497e56430a9cae58c3a09daf51 |
| properties           | 128                              |
| ram                  | 4096                             |
| rbac_policy          | 10                               |
| router               | 10                               |
| secgroup-rules       | 100                              |
| secgroups            | 10                               |
| server_group_members | 10                               |
| server_groups        | 10                               |
| snapshots            | 10                               |
| snapshots_iscsi      | -1                               |
| subnet               | 10                               |
| subnetpool           | -1                               |
| vip                  | 10                               |
| volumes              | 10                               |
| volumes_iscsi        | -1                               |
+----------------------+----------------------------------+


Additional info:

The quota isn't set either when using the project name

openstack quota set --cores 6 --ram 2048 project-limited
openstack quota show f5e9d7497e56430a9cae58c3a09daf51

+----------------------+----------------------------------+
| Field                | Value                            |
+----------------------+----------------------------------+
| backup_gigabytes     | 1000                             |
| backups              | 10                               |
| cores                | 5                                |
| fixed-ips            | -1                               |
| floating-ips         | 50                               |
| gigabytes            | 1000                             |
| gigabytes_iscsi      | -1                               |
| health_monitor       | -1                               |
| injected-file-size   | 10240                            |
| injected-files       | 5                                |
| injected-path-size   | 255                              |
| instances            | 10                               |
| key-pairs            | 100                              |
| member               | -1                               |
| network              | 10                               |
| per_volume_gigabytes | -1                               |
| pool                 | 10                               |
| port                 | 50                               |
| project              | f5e9d7497e56430a9cae58c3a09daf51 |
| properties           | 128                              |
| ram                  | 4096                             |
| rbac_policy          | 10                               |
| router               | 10                               |
| secgroup-rules       | 100                              |
| secgroups            | 10                               |
| server_group_members | 10                               |
| server_groups        | 10                               |
| snapshots            | 10                               |
| snapshots_iscsi      | -1                               |
| subnet               | 10                               |
| subnetpool           | -1                               |
| vip                  | 10                               |
| volumes              | 10                               |
| volumes_iscsi        | -1                               |
+----------------------+----------------------------------+

Comment 2 Jason E. Rist 2018-10-30 15:21:12 UTC
Closing. If this still seems like an issue, please re-open.

This is part of a bug closing  action due to lack of resources.
Age >3 months + Priority < High + No active customer reference


Note You need to log in before you can comment on or make changes to this bug.