Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355895 - User_data is being base64 encoded twice causing init script to fail for Openstack provisioning
Summary: User_data is being base64 encoded twice causing init script to fail for Opens...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.7.0
Assignee: Brandon Dunne
QA Contact: Leo Khomenko
URL:
Whiteboard:
: 1331806 (view as bug list)
Depends On: 1384506
Blocks: 1356251 1356706
TreeView+ depends on / blocked
 
Reported: 2016-07-12 21:12 UTC by Jared Deubel
Modified: 2017-05-03 18:27 UTC (History)
10 users (show)

Fixed In Version: 5.7.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1356251 1356706 (view as bug list)
Environment:
Last Closed: 2017-01-11 20:04:35 UTC
Category: ---
Cloudforms Team: ---


Attachments (Terms of Use)

Comment 2 Greg McCullough 2016-07-12 21:23:05 UTC
Brandon - Can you verify the issue here which I believe is related to the following:
Git Issue: https://github.com/ManageIQ/manageiq/issues/7344
PR: https://github.com/ManageIQ/manageiq/pull/7346

Comment 4 Brandon Dunne 2016-07-13 18:53:32 UTC
Based on the logging, this isn't AWS, it's openstack.  Jared, can you confirm that the users problem is with openstack as the logging indicates?

Comment 10 CFME Bot 2016-07-15 17:00:50 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/42582320062c6330c92a97931d8d624b24e4edda

commit 42582320062c6330c92a97931d8d624b24e4edda
Author:     Brandon Dunne <bdunne@redhat.com>
AuthorDate: Wed Jul 13 17:38:45 2016 -0400
Commit:     Brandon Dunne <bdunne@redhat.com>
CommitDate: Wed Jul 13 18:11:21 2016 -0400

    Don't Base64.encode64 by default, it doesn't apply to every provider
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1355895

 .../manageiq/providers/azure/cloud_manager/provision.rb       |  1 +
 .../providers/azure/cloud_manager/provision/configuration.rb  |  6 ++++++
 .../providers/cloud_manager/provision/configuration.rb        |  4 ++--
 .../azure/cloud_manager/provision/configuration_spec.rb       | 11 +++++++++++
 .../manageiq/providers/cloud_manager/configuration_spec.rb    |  6 +++---
 5 files changed, 23 insertions(+), 5 deletions(-)
 create mode 100644 app/models/manageiq/providers/azure/cloud_manager/provision/configuration.rb
 create mode 100644 spec/models/manageiq/providers/azure/cloud_manager/provision/configuration_spec.rb

Comment 11 CFME Bot 2016-07-15 17:00:55 UTC
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/d5c18983e85f7b522d93a8bf25c88ab3487f0d12

commit d5c18983e85f7b522d93a8bf25c88ab3487f0d12
Author:     Brandon Dunne <bdunne@redhat.com>
AuthorDate: Wed Jul 13 18:04:18 2016 -0400
Commit:     Brandon Dunne <bdunne@redhat.com>
CommitDate: Wed Jul 13 18:11:25 2016 -0400

    Remove extra contexts
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1355895

 .../azure/cloud_manager/provision/configuration_spec.rb    | 14 ++++++--------
 .../manageiq/providers/cloud_manager/configuration_spec.rb | 14 ++++++--------
 2 files changed, 12 insertions(+), 16 deletions(-)

Comment 12 CFME Bot 2016-07-15 18:16:51 UTC
New commit detected on manageiq-providers-amazon/master:
https://github.com/ManageIQ/manageiq-providers-amazon/commit/f4dae45b7841899def478834cc05dc565842614c

commit f4dae45b7841899def478834cc05dc565842614c
Author:     Brandon Dunne <bdunne@redhat.com>
AuthorDate: Wed Jul 13 18:10:30 2016 -0400
Commit:     Brandon Dunne <bdunne@redhat.com>
CommitDate: Fri Jul 15 12:32:12 2016 -0400

    Ensure user_data is Base64 encoded
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1355895

 .../providers/amazon/cloud_manager/provision/configuration.rb |  5 +++++
 .../amazon/cloud_manager/provision/configuration_spec.rb      | 11 +++++++++++
 2 files changed, 16 insertions(+)
 create mode 100644 spec/models/manageiq/providers/amazon/cloud_manager/provision/configuration_spec.rb

Comment 14 CFME Bot 2016-07-18 19:56:16 UTC
New commit detected on ManageIQ/manageiq/darga:
https://github.com/ManageIQ/manageiq/commit/bb54d03b333e93ca13dbdcf0afed1cabf4bce283

commit bb54d03b333e93ca13dbdcf0afed1cabf4bce283
Author:     Brandon Dunne <bdunne@redhat.com>
AuthorDate: Wed Jul 13 17:38:45 2016 -0400
Commit:     Brandon Dunne <bdunne@redhat.com>
CommitDate: Mon Jul 18 12:01:11 2016 -0400

    Don't Base64.encode64 by default, it doesn't apply to every provider
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1355895

 .../manageiq/providers/azure/cloud_manager/provision.rb       |  1 +
 .../providers/azure/cloud_manager/provision/configuration.rb  |  6 ++++++
 .../providers/cloud_manager/provision/configuration.rb        |  4 ++--
 .../providers/amazon/cloud_manager/provision/configuration.rb |  5 +++++
 .../amazon/cloud_manager/provision/configuration_spec.rb      | 11 +++++++++++
 .../azure/cloud_manager/provision/configuration_spec.rb       | 11 +++++++++++
 .../manageiq/providers/cloud_manager/configuration_spec.rb    |  6 +++---
 7 files changed, 39 insertions(+), 5 deletions(-)
 create mode 100644 app/models/manageiq/providers/azure/cloud_manager/provision/configuration.rb
 create mode 100644 gems/manageiq-providers-amazon/spec/models/manageiq/providers/amazon/cloud_manager/provision/configuration_spec.rb
 create mode 100644 spec/models/manageiq/providers/azure/cloud_manager/provision/configuration_spec.rb

Comment 15 CFME Bot 2016-07-18 19:56:20 UTC
New commit detected on ManageIQ/manageiq/darga:
https://github.com/ManageIQ/manageiq/commit/321791147d12ba1bd361090adb9f5f490826c34a

commit 321791147d12ba1bd361090adb9f5f490826c34a
Author:     Brandon Dunne <bdunne@redhat.com>
AuthorDate: Wed Jul 13 18:04:18 2016 -0400
Commit:     Brandon Dunne <bdunne@redhat.com>
CommitDate: Mon Jul 18 12:01:18 2016 -0400

    Remove extra contexts
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1355895

 .../azure/cloud_manager/provision/configuration_spec.rb    | 14 ++++++--------
 .../manageiq/providers/cloud_manager/configuration_spec.rb | 14 ++++++--------
 2 files changed, 12 insertions(+), 16 deletions(-)

Comment 18 Brandon Dunne 2016-08-02 14:16:51 UTC
This fix is merged to master and should be in "POST"

Comment 19 luke couzens 2016-08-30 13:06:11 UTC
*** Bug 1331806 has been marked as a duplicate of this bug. ***

Comment 24 Brandon Dunne 2016-11-15 14:08:07 UTC
Leo,  I'm not sure I understand your concern.  Are you testing against a provider and seeing an error?

Comment 25 Leo Khomenko 2016-11-15 15:37:40 UTC
I'm just asking - why do we have "\n" in user-data in fog.log? Such string is not a base64 and if one needs it he'll have remove them manually. 
provisioning with cloud_init now works and user-data is encoded only once

Comment 26 Leo Khomenko 2016-11-16 10:09:46 UTC
"\n" in user-data is an item for RFE. in general - user-data is encoded only once, as it should be


Note You need to log in before you can comment on or make changes to this bug.