Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355890 - rhel-osp-director: Scaling of computes post upgrade 8.0->9.0 failes with error: Error: Must pass neutron_admin_password to Class[Nova::Network::Neutron] at /var/lib/heat-config/heat-config-puppet/a7395778-7ffc-4977-9eb8-1bbcd31d16eb.pp:115
Summary: rhel-osp-director: Scaling of computes post upgrade 8.0->9.0 failes with erro...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Brent Eagles
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 20:15 UTC by Alexander Chuzhoy
Modified: 2016-07-20 12:44 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-20 12:44:18 UTC


Attachments (Terms of Use)

Description Alexander Chuzhoy 2016-07-12 20:15:42 UTC
rhel-osp-director: Scaling of computes post upgrade 8.0->9.0 failes with error: Error: Must pass neutron_admin_password to Class[Nova::Network::Neutron] at /var/lib/heat-config/heat-config-puppet/a7395778-7ffc-4977-9eb8-1bbcd31d16eb.pp:115

Environment:
openstack-tripleo-heat-templates-liberty-2.0.0-14.el7ost.noarch
openstack-puppet-modules-8.1.2-1.el7ost.noarch
instack-undercloud-4.0.0-6.el7ost.noarch
openstack-tripleo-heat-templates-kilo-2.0.0-14.el7ost.noarch
openstack-tripleo-heat-templates-2.0.0-14.el7ost.noarch

Steps to reproduce:
1. Deploy 8.0 with:
openstack overcloud deploy --templates --control-scale 3 --compute-scale 1 --ceph-storage-scale 2   --neutron-network-type vxlan --neutron-tunnel-types vxlan  --ntp-server 10.5.26.10 --timeout 90 -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e network-environment.yaml -e /home/stack/ssl-heat-templates/environments/enable-tls.yaml -e /home/stack/ssl-heat-templates/environments/inject-trust-anchor.yaml
2. Upgrade to 9.0
3. Attempt to scale the computes with:
openstack overcloud deploy --templates --control-scale 3 --compute-scale 2 --ceph-storage-scale 2   --neutron-network-type vxlan --neutron-tunnel-types vxlan  --ntp-server 10.5.26.10 --timeout 90 -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e network-environment.yaml -e /home/stack/ssl-heat-templates/environments/enable-tls.yaml -e /home/stack/ssl-heat-templates/environments/inject-trust-anchor.yaml


Result:
2016-02-12 02:32:53 [1]: SIGNAL_COMPLETE Unknown
2016-02-12 02:32:56 [ControllerDeployment]: SIGNAL_COMPLETE Unknown
2016-02-12 02:32:58 [NetworkDeployment]: SIGNAL_COMPLETE Unknown
2016-02-12 02:33:00 [2]: SIGNAL_COMPLETE Unknown
Stack overcloud UPDATE_FAILED
Deployment failed:  Heat Stack update failed.

{ "status": "FAILED", "server_id": "47f9219f-03cd-4d47-a3e3-547a07f1ec1b", "config_id": "a7395778-7ffc-4977-9eb8-1bbcd31d16eb", "output_values": { "deploy_stdout": "", "deploy_stderr": "Could not retrieve fact='apache_version', resolution='<anonymous>': undefined method `[]' for nil:NilClass
Could not retrieve fact='apache_version', resolution='<anonymous>': undefined method `[]' for nil:NilClass
Warning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::vncproxy::host'; class ::nova::vncproxy has not been evaluated
Warning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::vncproxy::vncproxy_protocol'; class ::nova::vncproxy has not been evaluated
Warning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::vncproxy::port'; class ::nova::vncproxy has not been evaluated
Warning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::vncproxy::vncproxy_path'; class ::nova::vncproxy has not been evaluated
Error: Must pass neutron_admin_password to Class[Nova::Network::Neutron] at /var/lib/heat-config/heat-config-puppet/a7395778-7ffc-4977-9eb8-1bbcd31d16eb.pp:115 on node overcloud-compute-1.localdomain
Error: Must pass neutron_admin_password to Class[Nova::Network::Neutron] at /var/lib/heat-config/heat-config-puppet/a7395778-7ffc-4977-9eb8-1bbcd31d16eb.pp:115 on node overcloud-compute-1.localdomain


[stack@undercloud72 ~]$

Expected result:
Successfuly scale up of computes.

Comment 3 Alexander Chuzhoy 2016-07-12 20:49:37 UTC
The heat log and the sosreports are here:
http://rhos-release.virt.bos.redhat.com/log/bz1355890

Comment 4 Brent Eagles 2016-07-19 18:15:02 UTC
@Sasha: were you able to confirm that the overcloud images were updated? Does this still happen if they have been?

Comment 5 Alexander Chuzhoy 2016-07-19 20:05:02 UTC
The overcloud images were not updated prior the scale attempt. 
This is probably not a bug.

Comment 6 Brent Eagles 2016-07-20 12:44:18 UTC
Cool, thanks! 

I'll close for now. We can re-open/re-file if new information arises.


Note You need to log in before you can comment on or make changes to this bug.