Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355821 - FTBFS due missing fence_zvm.h
Summary: FTBFS due missing fence_zvm.h
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fence-agents
Version: 25
Hardware: s390x
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Marek Grac
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ZedoraTracker
TreeView+ depends on / blocked
 
Reported: 2016-07-12 15:35 UTC by Dan Horák
Modified: 2016-08-30 18:17 UTC (History)
2 users (show)

Fixed In Version: fence-agents-4.0.24-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-30 18:17:57 UTC


Attachments (Terms of Use)

Description Dan Horák 2016-07-12 15:35:24 UTC
Build of new fence-agents fails on s390x due missing fence_zvm.h with

build.log
...
make[6]: Leaving directory '/builddir/build/BUILD/fence-agents-4.0.23/fence/agents'
set -e && \
PYTHONPATH=/builddir/build/BUILD/fence-agents-4.0.23/fence/agents/lib:/builddir/build/BUILD/fence-agents-4.0.23/fence/agents/../lib:/builddir/build/BUILD/fence-agents-4.0.23/fence/agents/lib \
	/usr/bin/python ilo_ssh/fence_ilo3_ssh -o metadata > ilo_ssh/.fence_ilo3_ssh.8.tmp && \
xmllint --noout --relaxng /builddir/build/BUILD/fence-agents-4.0.23/fence/agents/lib/metadata.rng ilo_ssh/.fence_ilo3_ssh.8.tmp && \
xsltproc ../../fence/agents/lib/fence2man.xsl ilo_ssh/.fence_ilo3_ssh.8.tmp > ilo_ssh/fence_ilo3_ssh.8
ilo/.fence_ilo2.8.tmp validates
xsltproc ../../fence/agents/lib/fence2wiki.xsl ilo/.fence_ilo2.8.tmp | grep -v '<?xml' > ilo/fence_ilo2.wiki
make[5]: Leaving directory '/builddir/build/BUILD/fence-agents-4.0.23/fence/agents'
gcc -DHAVE_CONFIG_H -I. -I../../make   -I../../make -I../../make -I.  -D_GNU_SOURCE -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -march=z9-109 -mtune=z10 -O2 -ggdb3 	 -Wall -Wshadow -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wdeclaration-after-statement -Wpointer-arith -Wwrite-strings -Wcast-align -Wbad-function-cast -Wmissing-format-attribute -Wformat=2 -Wformat-security -Wformat-nonliteral -Wno-long-long -Wno-strict-aliasing  -c -o zvm/zvm_fence_zvm-fence_zvm.o `test -f 'zvm/fence_zvm.c' || echo './'`zvm/fence_zvm.c
ilo_ssh/.fence_ilo3_ssh.8.tmp validates
xsltproc ../../fence/agents/lib/fence2wiki.xsl ilo_ssh/.fence_ilo3_ssh.8.tmp | grep -v '<?xml' > ilo_ssh/fence_ilo3_ssh.wiki
make[5]: Leaving directory '/builddir/build/BUILD/fence-agents-4.0.23/fence/agents'
/bin/sh ../../libtool  --tag=CC   --mode=link gcc -D_GNU_SOURCE -Ikdump -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -march=z9-109 -mtune=z10 -O2 -ggdb3 	 -Wall -Wshadow -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wdeclaration-after-statement -Wpointer-arith -Wwrite-strings -Wcast-align -Wbad-function-cast -Wmissing-format-attribute -Wformat=2 -Wformat-security -Wformat-nonliteral -Wno-long-long -Wno-strict-aliasing   -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -o kdump/fence_kdump_send kdump/kdump_fence_kdump_send-fence_kdump_send.o  
zvm/fence_zvm.c:48:23: fatal error: fence_zvm.h: No such file or directory
 #include "fence_zvm.h"
                       ^
make[5]: Entering directory '/builddir/build/BUILD/fence-agents-4.0.23/fence/agents'
set -e && \
PYTHONPATH=/builddir/build/BUILD/fence-agents-4.0.23/fence/agents/lib:/builddir/build/BUILD/fence-agents-4.0.23/fence/agents/../lib:/builddir/build/BUILD/fence-agents-4.0.23/fence/agents/lib \
	/usr/bin/python ilo_ssh/fence_ilo4_ssh -o metadata > ilo_ssh/.fence_ilo4_ssh.8.tmp && \
xmllint --noout --relaxng /builddir/build/BUILD/fence-agents-4.0.23/fence/agents/lib/metadata.rng ilo_ssh/.fence_ilo4_ssh.8.tmp && \
xsltproc ../../fence/agents/lib/fence2man.xsl ilo_ssh/.fence_ilo4_ssh.8.tmp > ilo_ssh/fence_ilo4_ssh.8
compilation terminated.
Makefile:726: recipe for target 'zvm/zvm_fence_zvm-fence_zvm.o' failed
make[3]: *** [zvm/zvm_fence_zvm-fence_zvm.o] Error 1
make[3]: *** Waiting for unfinished jobs....
ilo_ssh/.fence_ilo4_ssh.8.tmp validates
xsltproc ../../fence/agents/lib/fence2wiki.xsl ilo_ssh/.fence_ilo4_ssh.8.tmp | grep -v '<?xml' > ilo_ssh/fence_ilo4_ssh.wiki
make[5]: Leaving directory '/builddir/build/BUILD/fence-agents-4.0.23/fence/agents'
set -e && \
PYTHONPATH=/builddir/build/BUILD/fence-agents-4.0.23/fence/agents/lib:/builddir/build/BUILD/fence-agents-4.0.23/fence/agents/../lib:/builddir/build/BUILD/fence-agents-4.0.23/fence/agents/lib \
	/usr/bin/python apc_snmp/fence_tripplite_snmp -o metadata > apc_snmp/.fence_tripplite_snmp.8.tmp && \
xmllint --noout --relaxng /builddir/build/BUILD/fence-agents-4.0.23/fence/agents/lib/metadata.rng apc_snmp/.fence_tripplite_snmp.8.tmp && \
xsltproc ../../fence/agents/lib/fence2man.xsl apc_snmp/.fence_tripplite_snmp.8.tmp > apc_snmp/fence_tripplite_snmp.8
apc_snmp/.fence_tripplite_snmp.8.tmp validates
xsltproc ../../fence/agents/lib/fence2wiki.xsl apc_snmp/.fence_tripplite_snmp.8.tmp | grep -v '<?xml' > apc_snmp/fence_tripplite_snmp.wiki
make[4]: Leaving directory '/builddir/build/BUILD/fence-agents-4.0.23/fence/agents'
libtool: link: gcc -D_GNU_SOURCE -Ikdump -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -march=z9-109 -mtune=z10 -O2 -ggdb3 -Wall -Wshadow -Wmissing-prototypes -Wmissing-declarations -Wstrict-prototypes -Wdeclaration-after-statement -Wpointer-arith -Wwrite-strings -Wcast-align -Wbad-function-cast -Wmissing-format-attribute -Wformat=2 -Wformat-security -Wformat-nonliteral -Wno-long-long -Wno-strict-aliasing -Wl,-z -Wl,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -o kdump/fence_kdump_send kdump/kdump_fence_kdump_send-fence_kdump_send.o 
make[3]: Leaving directory '/builddir/build/BUILD/fence-agents-4.0.23/fence/agents'
Makefile:387: recipe for target 'all-recursive' failed
make[2]: Leaving directory '/builddir/build/BUILD/fence-agents-4.0.23/fence'
make[2]: *** [all-recursive] Error 1
Makefile:449: recipe for target 'all-recursive' failed
make[1]: Leaving directory '/builddir/build/BUILD/fence-agents-4.0.23'
make[1]: *** [all-recursive] Error 1
Makefile:381: recipe for target 'all' failed
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.Szjeiq (%build)
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.Szjeiq (%build)
Child return code was: 1
EXCEPTION: Command failed. See logs for output.
 # bash --login -c /usr/bin/rpmbuild -bb --target s390x --nodeps  /builddir/build/SPECS/fence-agents.spec 
Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/mockbuild/trace_decorator.py", line 88, in trace
    result = func(*args, **kw)
  File "/usr/lib/python3.4/site-packages/mockbuild/util.py", line 547, in do
    raise exception.Error("Command failed. See logs for output.\n # %s" % (command,), child.returncode)
mockbuild.exception.Error: Command failed. See logs for output.
 # bash --login -c /usr/bin/rpmbuild -bb --target s390x --nodeps  /builddir/build/SPECS/fence-agents.spec 
LEAVE do --> EXCEPTION RAISED
...

for full logs please see http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2285371


Version-Release number of selected component (if applicable):
fence-agents-4.0.23-1.fc25

Comment 1 Oyvind Albrigtsen 2016-07-13 11:06:10 UTC
I've now done a build where this should be fixed.

Can you try building fence-agents-4.0.23-2.fc25 for s390x?

Comment 2 Oyvind Albrigtsen 2016-07-13 11:14:31 UTC
Sorry about that. There appears to be some issue with the source archive, so I'll inform you when I've updated it so that it contains fence_zvm.h.

Comment 3 Dan Horák 2016-07-13 11:21:18 UTC
still the same problem - http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=2286606
Looks to me the fence_zvm.h file is not included in the source archive at all.

And you can try the build on secondary arches yourself with eg. 
s390-koji build --scratch f25 fence-agents-4.0.23-2.fc25.src.rpm
(and subst s390 for ppc or arm for ppc64/ppc64 or aarch64 scratch builds)

Comment 4 Jan Kurik 2016-07-26 04:43:47 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 5 Oyvind Albrigtsen 2016-08-26 11:03:28 UTC
New build has been tested with "s390-koji build --scratch f25 ..." and worked as expected.

Comment 6 Fedora Update System 2016-08-26 11:05:34 UTC
fence-agents-4.0.24-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-21cae0bccb

Comment 7 Fedora Update System 2016-08-27 12:53:46 UTC
fence-agents-4.0.24-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-21cae0bccb

Comment 8 Fedora Update System 2016-08-30 18:17:54 UTC
fence-agents-4.0.24-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.