Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355809 - Mislabeled file /dev/ndctl0 system_u:object_r:device_t:SystemLow
Summary: Mislabeled file /dev/ndctl0 system_u:object_r:device_t:SystemLow
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 14:58 UTC by Jiri Jaburek
Modified: 2016-11-04 02:34 UTC (History)
8 users (show)

Fixed In Version: selinux-policy-3.13.1-89.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1312317
Environment:
Last Closed: 2016-11-04 02:34:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2283 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2016-11-03 13:36:25 UTC

Description Jiri Jaburek 2016-07-12 14:58:03 UTC
+++ This bug was initially created as a clone of Bug #1312317 +++

Description of problem:
The device ndctl0 does not have a correct label.

/dev/ndctl0 system_u:object_r:device_t:SystemLow

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-85.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. ls -Z /dev/ndctl0

Actual results:
Generic type device_t

Expected results:
Should be a non-generic type

Comment 1 Ondrej Moriš 2016-07-13 10:06:02 UTC
According to the documentation [1] the only appropriate existing types are nvram_device_t and nv_me_device_t. I would prefer nvram_device_t. It would be good to have this in 7.3.0 since this bug is on RHEL7RetainCCC tracker which contains bugs related to Common Criteria (even though this one is not directly related).

[1] https://www.kernel.org/doc/Documentation/nvdimm/nvdimm.txt

Comment 8 errata-xmlrpc 2016-11-04 02:34:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html


Note You need to log in before you can comment on or make changes to this bug.