Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355795 - Boot drive should fallback to --driveorder parameter or disk with /boot on it
Summary: Boot drive should fallback to --driveorder parameter or disk with /boot on it
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.3
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jiri Konecny
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 14:35 UTC by Jiri Konecny
Modified: 2016-11-03 23:25 UTC (History)
3 users (show)

Fixed In Version: anaconda-21.48.22.81-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-03 23:25:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2158 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2016-11-03 13:13:55 UTC

Description Jiri Konecny 2016-07-12 14:35:17 UTC
Description of problem:
When bootloader doesn't have --boot-drive parameter then a first disk from Blivet is used. It looks like Blivet is sorting the disk alphanumerically so the bootloader is written to 'sda' or 'vda' and similar. 
Boot drive should be taken from --driveorder and if --driveorder is not present then take disk where /boot is. If nothing can be used, take first from Blivet.

Version-Release number of selected component (if applicable):
anaconda-25.20-1

How reproducible:
Always

Steps to Reproduce:
1. Create KS with bootloader "bootloader --location=mbr" (or specify --driveorder) and with /boot on disk /dev/sdb or /dev/vdb  and other required stuff for auto-install
2. Start fully automatic installation with KS
3. After the installation, look to the program log to see if grub2-install is used on the disk where /boot is (or first disk in --driveorder field if specified)

Actual results:
Without the --boot-drive the bootloader is installed to first disk

Expected results:
The bootloader should be installed to a first disk from --driverorder field or /boot if driveorder isn't specified.

Comment 3 Jiri Konecny 2016-07-13 06:24:42 UTC
PR: https://github.com/rhinstaller/anaconda/pull/700

Comment 5 Jiri Konecny 2016-07-19 15:22:17 UTC
PR: https://github.com/rhinstaller/anaconda/pull/706

Comment 7 Michal Kovarik 2016-09-06 12:43:04 UTC
Reproduced on RHEL-7.2, verified on RHEL-7.3-20160901.1 with anaconda-21.48.22.86-1.

Comment 9 errata-xmlrpc 2016-11-03 23:25:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html


Note You need to log in before you can comment on or make changes to this bug.