Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355784 - Missing dep on systemd-container
Summary: Missing dep on systemd-container
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libvirt
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1356448 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 14:16 UTC by Daniel Berrange
Modified: 2016-07-22 15:58 UTC (History)
10 users (show)

Fixed In Version: libvirt-1.3.3.2-1.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-22 15:58:11 UTC


Attachments (Terms of Use)

Description Daniel Berrange 2016-07-12 14:16:51 UTC
Description of problem:
On systemd installs, libvirt prefers to delegate cgroup creation to systemd. It does this dynamically by detecting if systemd-machined is present, but on Fedora 24 this was split out of the main systemd RPM. We need to depend on systemd-container now, from libvirt-daemon-driver-lxc and libvirt-daemon-driver-qemu

Version-Release number of selected component (if applicable):
1.3.3.104.fc24

Comment 1 Cole Robinson 2016-07-13 18:16:34 UTC
commit ffc49e579c14b1d3f24af8d004ded6e3a0e8900f
Author: Daniel P. Berrange <berrange@redhat.com>
Date:   Tue Jul 12 15:57:39 2016 +0100

    libvirt.spec.in: require systemd-container on >= f24

Comment 2 Cole Robinson 2016-07-18 13:22:30 UTC
*** Bug 1356448 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2016-07-19 11:25:37 UTC
libvirt-1.3.3.2-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-65cc608ebe

Comment 4 Fedora Update System 2016-07-20 01:53:51 UTC
libvirt-1.3.3.2-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-65cc608ebe

Comment 5 Fedora Update System 2016-07-22 15:57:03 UTC
libvirt-1.3.3.2-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.