Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355783 - virt_sandbox_use_nfs not created when docker-selinux 1.10.3-44.el7 installed causing OpenShift install failure
Summary: virt_sandbox_use_nfs not created when docker-selinux 1.10.3-44.el7 installed...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.2
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 14:16 UTC by Mike Fiedler
Modified: 2016-11-09 22:34 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 02:33:58 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2283 normal SHIPPED_LIVE selinux-policy bug fix and enhancement update 2016-11-03 13:36:25 UTC

Description Mike Fiedler 2016-07-12 14:16:11 UTC
Description of problem:

SELinux boolean  virt_sandbox_use_nfs  is not created when docker-selinux-

This causes OpenShift install failures

Version-Release number of selected component (if applicable):

docker-selinux 1.10.3-44.el7 


How reproducible: Always


Steps to Reproduce:
1. Install docker-selinux 1.10.3-44.el7 
2. semanage boolean -l | grep virt_sandbox_use_nfs


Actual results:

Boolean is missing


Expected results:

Boolean exists

Additional info:

If build  1.10.3-42.el7 is installed, the boolean exists.

Comment 1 Daniel Walsh 2016-07-12 14:51:27 UTC
You were building/installing in the 7.3 branch correct?

Comment 3 Mike Fiedler 2016-07-12 17:33:55 UTC
Problem system is RHEL 7.3 Beta.   Trying on RHEL 7.2

Comment 4 Mike Fiedler 2016-07-21 12:48:42 UTC
From Dan Walsh:

The problem is we have an update problem between the policy used in rhel7.3 versus rhel7.2.6.  docker-selinux is built for 7.2.6 and is blowing up with the newer selinux-policy package in 7.3 release.  We really need to different versions of docker-selinux, one for 7.3 which is built from master while 7.2.6 will still use from the rhel7-1.10 branch.

Comment 5 Daniel Walsh 2016-08-19 20:45:32 UTC
I believe this is straightened out in the current pools.

Comment 8 Daniel Walsh 2016-09-22 12:11:49 UTC
It is an alias for virt_use_nfs

# grep virt_sandbox_use_nfs /etc/selinux/targeted/booleans.subs_dist 
virt_sandbox_use_nfs virt_use_nfs

If you do

setsebool -P virt_sandbox_use_nfs 1

It should succeed, but it is really setting virt_use_nfs.

Comment 9 Guohua Ouyang 2016-09-23 03:24:47 UTC
# rpm -q docker-selinux
docker-selinux-1.10.3-55.el7.x86_64
# grep virt_sandbox_use_nfs /etc/selinux/targeted/booleans.subs_dist 
# setsebool -P virt_sandbox_use_nfs 1
Boolean virt_sandbox_use_nfs is not defined

it's not working here.

Comment 10 Daniel Walsh 2016-09-23 12:37:41 UTC
Looks like it is fixed in the rhel7.3 update then.

Comment 11 Daniel Walsh 2016-09-27 19:08:50 UTC
If this does not exist in selinux-policy package in RHEL, then this is their bug. Can not fix this in Docker.

Comment 12 Daniel Walsh 2016-09-27 20:39:43 UTC
Need to add 
virt_sandbox_use_nfs virt_use_nfs

to /etc/selinux/targeted/booleans.subs_dist

Comment 13 Daniel Walsh 2016-09-27 20:53:12 UTC
Fixed in selinux-policy- 3.13.1-102

Comment 19 errata-xmlrpc 2016-11-04 02:33:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html

Comment 20 Chris Pitman 2016-11-09 18:22:09 UTC
I am seeing this issue happening with selinux-policy 3.13.1-102 and docker-selinux 1.10.3-57 on RHEL 7.2.

Comment 21 Daniel Walsh 2016-11-09 22:34:41 UTC
yum reinstall selinux-policy-targeted docker-selinux

Do you see errors?


Note You need to log in before you can comment on or make changes to this bug.