Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355777 - OutOfMemoryError after reloading the server several times with Java 6 and 7
Summary: OutOfMemoryError after reloading the server several times with Java 6 and 7
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid, Documentation
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: ---
Assignee: David Le Sage
QA Contact: Filip Elias
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 14:06 UTC by Andrej Smigala
Modified: 2017-06-06 03:04 UTC (History)
9 users (show)

Doc Type: Known Issue
Doc Text:
If you run reload several times on a server started with Java 6 or 7, you will encounter an OutOfMemoryError. To work around this issue, you can remove the Dashboard Builder component if you are not using it.
Clone Of:
Environment:
Java 6 and 7
Last Closed: 2017-06-06 03:04:41 UTC
Type: Bug


Attachments (Terms of Use)

Description Andrej Smigala 2016-07-12 14:06:02 UTC
Running reload several times on a server started with Java 6 or 7 causes OutOfMemoryError.

You can use this bash script to reproduce (start the server first and cd into $JBOSS_HOME before running):


RELOAD_COUNT=0; while true; do if bin/jboss-cli.sh --connect --command=":reload" >/dev/null 2>&1 ; then ((RELOAD_COUNT++)) ; echo $RELOAD_COUNT; else test $? -gt 128 && break; fi; sleep 2; done


The OOM usually happens after 15-20 reloads with Java 6 and 20-25 reloads with Java 7. Server running with Java 8 survives 60+ reloads without error.

Comment 2 Van Halbert 2016-07-12 16:02:38 UTC
I've duplicated the issue with your script.  And confirmed that if dashboard builder is removed, the issue isn't seen.  I've run upwards of 80 reloads (still running) without seeing the issue when dashboard is removed.

Comment 9 David Le Sage 2017-05-11 03:31:59 UTC
Release note added.


Note You need to log in before you can comment on or make changes to this bug.