Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355757 - Missing API Port on Infra Provider Summary Properties
Summary: Missing API Port on Infra Provider Summary Properties
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.5.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Marek Aufart
QA Contact: Ola Pavlenko
URL:
Whiteboard: openstack
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 12:47 UTC by Ronnie Rasouli
Modified: 2017-08-21 13:09 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-21 13:07:20 UTC
Category: ---
Cloudforms Team: Openstack


Attachments (Terms of Use)
screenshot of missing API Port (deleted)
2016-07-12 12:47 UTC, Ronnie Rasouli
no flags Details

Description Ronnie Rasouli 2016-07-12 12:47:27 UTC
Created attachment 1178898 [details]
screenshot of missing API Port

Description of problem:

The API Port is missing on the display summary of infra provider

Version-Release number of selected component (if applicable):
5.5.5 with RHOS8

How reproducible:
100%

Steps to Reproduce:
1. login to CFME UI
2. add new infra provider the default API port is 5000
3. refresh the provider relationships 
4. all infra provider appears, the API port is missing

Actual results:

Missing API Port on infra provider summary

Expected results:

API Port shown

Additional info:

Comment 3 CFME Bot 2016-08-02 22:37:22 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=42d89bcf045cadf56d1547cd04b972082fb43301

commit 42d89bcf045cadf56d1547cd04b972082fb43301
Merge: 299e036 f243a5c
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Tue Aug 2 18:37:15 2016 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Tue Aug 2 18:37:15 2016 -0400

    Merge branch 'bz_1355757' into '5.5.z'
    
    Fix openstack infra provider nil default port value
    
    This is a quick dirty fix of not set port in openstack infra provider in 5.5.z.
    
    If provider is an openstack infra and port is nil, which does not make a sense,
    sets default port 5000.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1355757
    
    See merge request !1007

 app/controllers/ems_common.rb | 5 +++++
 1 file changed, 5 insertions(+)

Comment 4 CFME Bot 2016-08-02 22:37:26 UTC
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=f243a5c457f99b2312e82cc140eefee83f106b04

commit f243a5c457f99b2312e82cc140eefee83f106b04
Author:     Marek Aufart <maufart@redhat.com>
AuthorDate: Tue Jul 12 16:40:06 2016 +0200
Commit:     Marek Aufart <maufart@redhat.com>
CommitDate: Tue Jul 12 16:40:06 2016 +0200

    Fix openstack infra provider nil defaul port value
    
    This is a quick dirty fix of not set port in openstack infra provider in 5.5.z.
    
    If provider is an openstack infra and port is nil, which does not make a sense,
    sets default port 5000.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1355757

 app/controllers/ems_common.rb | 5 +++++
 1 file changed, 5 insertions(+)

Comment 5 Chris Pelland 2017-08-21 13:07:20 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.

Comment 6 Chris Pelland 2017-08-21 13:09:40 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.