Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355751 - Edit VM for a RHEV VM: Parent/Child VM Selection fields do not contain valid information [NEEDINFO]
Summary: Edit VM for a RHEV VM: Parent/Child VM Selection fields do not contain valid ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Oved Ourfali
QA Contact: Ilanit Stein
URL:
Whiteboard: rhev
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 12:34 UTC by Ilanit Stein
Modified: 2018-01-05 23:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-21 13:02:28 UTC
Category: ---
Cloudforms Team: RHEVM
oourfali: needinfo? (mgoldboi)
oourfali: needinfo? (jhardy)


Attachments (Terms of Use)
Edit VM for RHEV screenshot (deleted)
2016-07-12 12:34 UTC, Ilanit Stein
no flags Details

Description Ilanit Stein 2016-07-12 12:34:26 UTC
Created attachment 1178889 [details]
Edit VM for RHEV screenshot

Description of problem:
"Parent VM selection" - 
This field should contain the VM name, from which the Edited VM was cloned. 
For a RHEV cloned VM, it do not show the parent VM (The field is empty).

"Child VM Selection" - 
This field should contain the VM names, that were cloned from the Edited VM. 
For a RHEV VM, that has cloned VMs, the cloned VMs are not displayed here, as expected (This field is empty).

Version-Release number of selected component (if applicable):
CFME 5.6.0.11-rc2.2.20160614152915_f315c68
RHEVM-3.6.6.2-0.1.el6

How reproducible:
100%

Additional info:
Need to take into account that the VM genealogy, is also displayed in the VM summary page, under relationships, and need to make sure the information there is correct, as well.

Comment 2 Oved Ourfali 2016-07-27 04:52:59 UTC
I don't think that in RHEV this information is kept anywhere.
If you clone a VM from another then there is no relationship between the two.
The best that can be done here is to show the template from which the VM was created I guess.

Tomas - thoughts?

Comment 3 Tomas Jelinek 2016-07-27 05:58:18 UTC
No, the parent from which the VM has been cloned is not displayed.
Even the original template may be an issue. It is kept only when you use thin provisioning. If you use clone provisioning, it is kept in a special columns in DB "original_template_id/name" but this info is only sent back to the frontend and is not returned by the API. The API in the case of clone provisioning only returns the reference to Blank template.

I see 2 options:
- enrich the engine to keep this info and return using API (could be done in ovirt 4.1 timeframe theoretically)
- start returning also the original template ID/name for clone provisioned VMs using the API (also, theoretically ovirt 4.1)
- hide this field from CFME

I would vote for the third option.
What you think?

Comment 4 Oved Ourfali 2016-07-27 06:04:40 UTC
I tend to go with option #3.

John - your thoughts?

Comment 5 Oved Ourfali 2016-11-21 10:22:50 UTC
John - your thoughts?

Comment 6 Chris Pelland 2017-08-21 13:02:28 UTC
This bug has been open for more than a year and is assigned to an older release of CloudForms. 

If you would like to keep this Bugzilla open and if the issue is still present in the latest version of the product, please file a new Bugzilla which will be added and assigned to the latest release of CloudForms.


Note You need to log in before you can comment on or make changes to this bug.