Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355737 - SELinux is preventing systemctl from 'connectto' accesses on the unix_stream_socket /run/systemd/private.
Summary: SELinux is preventing systemctl from 'connectto' accesses on the unix_stream_...
Keywords:
Status: CLOSED DUPLICATE of bug 1235293
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 23
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:95e104289dc784b2eb571d58d20...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 11:51 UTC by Laurent Rineau
Modified: 2016-07-12 12:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-12 12:02:51 UTC


Attachments (Terms of Use)

Description Laurent Rineau 2016-07-12 11:51:01 UTC
Description of problem:
I restarted dnssec with:

    sudo systemctl restart dnssec-triggerd.service
SELinux is preventing systemctl from 'connectto' accesses on the unix_stream_socket /run/systemd/private.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that systemctl should be allowed connectto access on the private unix_stream_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'systemctl' --raw | audit2allow -M my-systemctl
# semodule -X 300 -i my-systemctl.pp

Additional Information:
Source Context                system_u:system_r:dnssec_trigger_t:s0
Target Context                system_u:system_r:init_t:s0
Target Objects                /run/systemd/private [ unix_stream_socket ]
Source                        systemctl
Source Path                   systemctl
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-158.15.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.5.7-202.fc23.x86_64 #1 SMP Tue
                              Jun 28 18:22:51 UTC 2016 x86_64 x86_64
Alert Count                   1
First Seen                    2016-07-12 13:43:20 CEST
Last Seen                     2016-07-12 13:43:20 CEST
Local ID                      cd38a54b-0a59-4412-a000-baee684e9da2

Raw Audit Messages
type=AVC msg=audit(1468323800.694:943): avc:  denied  { connectto } for  pid=7250 comm="systemctl" path="/run/systemd/private" scontext=system_u:system_r:dnssec_trigger_t:s0 tcontext=system_u:system_r:init_t:s0 tclass=unix_stream_socket permissive=1


Hash: systemctl,dnssec_trigger_t,init_t,unix_stream_socket,connectto

Version-Release number of selected component:
selinux-policy-3.13.1-158.15.fc23.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.5.7-202.fc23.x86_64
type:           libreport

Potential duplicate: bug 1235293

Comment 1 Laurent Rineau 2016-07-12 12:02:51 UTC

*** This bug has been marked as a duplicate of bug 1235293 ***


Note You need to log in before you can comment on or make changes to this bug.