Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355727 - PRETTY_NAME=CloudForms show on RHVH login screen and cockpit UI after RHVH registered to RHSM
Summary: PRETTY_NAME=CloudForms show on RHVH login screen and cockpit UI after RHVH re...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-release-rhev-hypervisor
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.0.2
: ---
Assignee: Ryan Barry
QA Contact: Ying Cui
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 11:12 UTC by Ying Cui
Modified: 2016-08-23 21:12 UTC (History)
11 users (show)

Fixed In Version: redhat-release-virtualization-host-4.0-0.25.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 21:12:55 UTC
oVirt Team: Node


Attachments (Terms of Use)
screenshot (deleted)
2016-07-12 11:19 UTC, Ying Cui
no flags Details
varlog.tar.bz2 (deleted)
2016-07-12 11:22 UTC, Ying Cui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1688 normal SHIPPED_LIVE redhat-release-virtualization-host bug fix and enhancement update for RHV 4.0 2016-08-24 00:37:04 UTC
Red Hat Bugzilla 1357648 None CLOSED Brandbot cannot be disabled 2019-01-15 23:07:19 UTC

Internal Links: 1357648

Description Ying Cui 2016-07-12 11:12:42 UTC
Description of problem:
After RHVH registered to RHSM, then rebooted RHVH, here in RHVH login screen and cockpit UI, there display "CloudForms" rather than VARIANT="Red Hat Virtualization Hypervisor"


Version-Release number of selected component (if applicable):
imgbased-0.7.2-0.1.el7ev.noarch
cockpit-ovirt-dashboard-0.10.6-1.2.0.el7ev.noarch
subscription-manager-1.15.9-15.el7.x86_64
cockpit-0.108-1.el7.x86_64
RHVH-7.2-20160708.2-RHVH-x86_64-dvd1.iso

How reproducible:
100%

Steps to Reproduce:
1. Installed RHVH using the default ks.cfg in ISO successful.
2. Access cockpit UI: https://ip-address-of-machine:9090
3. Navigate to subscription-manager via cockpit:https://ip-address-of-machine:9090/subscriptions
4. Subscribed the RHSM successful.
5. Reboot RHVH
6. After reboot, login the RHVH and access the cockpit UI

Actual results:
In step 6, there display "CloudForms" rather than "Red Hat Virtualization Hypervisor"

Expected results:
Here should display RHVH info

Additional info:
# cat /etc/os-release 
NAME="Red Hat Enterprise Linux"
VERSION="7.2"
VERSION_ID="7.2"
ID="rhel"
ID_LIKE="fedora"
VARIANT="Red Hat Virtualization Hypervisor"
VARIANT_ID="ovirt-node"
PRETTY_NAME=CloudForms   # <---------display in UI and RHVH login screen.
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:7.2:beta:hypervisor"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

# FIXME
REDHAT_BUGZILLA_PRODUCT="Red Hat Virtualization"
REDHAT_BUGZILLA_PRODUCT_VERSION=7.2
REDHAT_SUPPORT_PRODUCT="Red Hat Virtualization"
REDHAT_SUPPORT_PRODUCT_VERSION=7.2

Comment 1 Ying Cui 2016-07-12 11:19:30 UTC
Created attachment 1178861 [details]
screenshot

Comment 2 Ying Cui 2016-07-12 11:22:52 UTC
Created attachment 1178862 [details]
varlog.tar.bz2

Comment 3 Ying Cui 2016-07-13 03:27:27 UTC
Ryan, could you check this issue? It affects RHVH 4.0 beta 2.

Comment 4 Ryan Barry 2016-07-13 04:18:42 UTC
I'll check first thing in the morning

Comment 5 Ryan Barry 2016-07-13 14:40:10 UTC
Ok, I'm not able to reproduce this connecting to staging.

Checking prod.

Comment 6 Ryan Barry 2016-07-13 15:09:00 UTC
A reboot is only necessary here because cockpit caches this.

The value of /etc/os-release:PRETTY_NAME should change immediately after attaching (this is also observable from the command line via "subscription-manager register && subscription-manager attach -auto")

I cannot reproduce this on prod, either. But my PRETTY_NAME changes to "Employee SKU" (on prod, where my account has that entitlement).

Using a staging account where the only granted SKU is for RHEV, I don't observe a change in PRETTY_NAME.

This is also the case when 69.pem is present (registering to stage).

This leads me to believe that this change is somehow tied to account entitlements.

Chris (you're in the changelog):

How does subscription-manager choose when and if to change PRETTY_NAME?

And can this behavior be changed? We don't want RHEV-specific logic in upstream cockpit, but we DO want this behavior disabled on RHV hosts (if a customer uses an account which has an entitlement to CloudForms, for example).

Comment 17 Robert Riggs 2016-07-22 17:49:35 UTC
I am not sure what "brand_type" is or what I set that would affect that.  Any idea?

Comment 21 Ying Cui 2016-08-08 06:31:07 UTC
VERIFIED on redhat-release-virtualization-host-4.0-0.26.el7(RHVH-7.2-20160804.0-RHVH-x86_64-dvd1.iso)

Test Steps:
1. Installed RHVH using the default ks.cfg in ISO successful.
2. Access cockpit UI: https://ip-address-of-machine:9090
3. Navigate to subscription-manager via cockpit:https://ip-address-of-machine:9090/subscriptions
4. Subscribed the RHSM successful.
5. Reboot RHVH
6. After reboot, login the RHVH and access the cockpit UI

Result:
After step 6, the UI display RHVH info(Red Hat Virtualization Host 4.0 (el7.2))

Comment 23 errata-xmlrpc 2016-08-23 21:12:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1688.html


Note You need to log in before you can comment on or make changes to this bug.