Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355718 - ipa-replica-manage man page example output differs actual command output
Summary: ipa-replica-manage man page example output differs actual command output
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 10:45 UTC by Abhijeet Kasurde
Modified: 2016-11-04 05:57 UTC (History)
5 users (show)

Fixed In Version: ipa-4.4.0-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:57:32 UTC
Target Upstream Version:


Attachments (Terms of Use)
evidence (deleted)
2016-09-16 06:33 UTC, Pavel Picka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Abhijeet Kasurde 2016-07-12 10:45:06 UTC
Description of problem:
ipa-replica-manage man page example about command `ipa-replica-manage list` differs actual output

$ man ipa-replica-manage
<snip>
EXAMPLES
       List all masters:
               # ipa-replica-manage list
               srv1.example.com
               srv2.example.com
               srv3.example.com
               srv4.example.com

       List a server's replication agreements.
               # ipa-replica-manage list srv1.example.com
               srv2.example.com
               srv3.example.com
<snip>


$ ipa-replica-manage list
srv1.example.com: master
srv2.example.com: master
srv3.example.com: master
srv4.example.com: master

$ ipa-replica-manage list srv1.example.com
srv2.example.com: replica
srv3.example.com: replica

Version-Release number of selected component (if applicable):
ipa-server-4.4.0-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. man ipa-replica-mange
2. ipa-replica-manage list

Actual results:
Example given in Man page differ actual command output

Expected results:
Example given in Man Page should match actual command output

Comment 2 Petr Vobornik 2016-07-12 15:33:26 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6058

Comment 3 Martin Bašti 2016-07-28 11:07:38 UTC
Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/0253f3d7319442150c37fe62e7c9f3f985406ccb

Comment 5 Pavel Picka 2016-09-16 06:33:41 UTC
Created attachment 1201542 [details]
evidence

Verified

4.4.0-11

Comment 7 errata-xmlrpc 2016-11-04 05:57:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.