Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355716 - [ALL_LANG] Unlocalized tool-tips on host->new->kernel tab.
Summary: [ALL_LANG] Unlocalized tool-tips on host->new->kernel tab.
Keywords:
Status: CLOSED DUPLICATE of bug 1422455
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.0.3
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: ovirt-4.1.2
: ---
Assignee: jniederm
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 10:41 UTC by Bhushan Barve
Modified: 2017-03-01 11:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-01 11:16:41 UTC
oVirt Team: Virt
tjelinek: ovirt-4.1?
bbarve: planning_ack?
bbarve: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
tool-tips untranslated (deleted)
2016-07-12 10:41 UTC, Bhushan Barve
no flags Details
hosts-new-kernel tab's unlocalized tool-tips and warning messages (deleted)
2016-08-05 09:31 UTC, Krishna Babu K
no flags Details

Description Bhushan Barve 2016-07-12 10:41:52 UTC
Created attachment 1178850 [details]
tool-tips untranslated

Description of problem: The Host > new > Kernel tab contains 5 unlocalized tool tips. See attached screenshot. 


Version-Release number of selected component (if applicable):
 Red Hat Enterprise Virtualization Manager バージョン: 4.0.2-0.2.rc1.el7ev 

How reproducible:
always

Steps to Reproduce:
1. login with ja_JP locale 
2. go to Host > new > Kernel tab
3. check the 5 tool-tips (with ? sign)

Actual results:
The tool-tips are untranslated

Expected results:
The tool-tips should be translated.

Additional info:

Comment 1 sandeep shedmake 2016-07-12 11:56:32 UTC
From Comment 0,


(1) Hosts > New > New Host > Kernel > Kernel boot parameters > Hostdev Passthrough & SR-IOV > 'Help' icon message appear in English

- Enables or disables host's IOMMU, allowing PCI passthrough devices to be added to guests. Has no effect unless IOMMU is supported by the hardware and enabled in a firmware.


(2) Hosts > New > New Host > Kernel > Kernel boot parameters > Nested Virtualization > 'Help' icon message appear in English

- Enables or disables nested virtualization. Nested virtualization passes vmx/svm (hardware virtualization flag) to guest operating system.
Requires vsdm 'nestedvt' hook.


(3) Hosts > New > New Host > Kernel > Kernel boot parameters > Unsafe Interrupts > 'Help' icon message appear in English 

- Enables or disables unsafe interrupt remapping. Should only be enabled if VMs with PCI passthrough devices cannot be started and 'dmesg'
command indicates that it should be enabled (search for 'No interrupt remapping support.').


(4) Hosts > New > New Host > Kernel > Kernel boot parameters > PCI Reallocation > 'Help' icon message appear in English 

- Enables or disables reallocation of PCI bridge resources. Some firmware does not correctly handle SR-IOV devices, disallowing VF creation. Dynamic reallocation attempts to solve this problem. Does not help on unsupported hardware.


(5) Hosts > New > New Host > Kernel > Kernel boot parameters > Kernel command line > 'Help' icon message appear in English 

- This is not the entire kernel command line. Parameters listed below will be added to default kernel parameters



The above strings appear in English as they are not marked for translation (possibly).

Thereby, requesting devel to mark the above strings for translation.

Comment 2 Krishna Babu K 2016-08-05 09:31:33 UTC
Created attachment 1187807 [details]
hosts-new-kernel tab's unlocalized tool-tips and warning messages

Verified on Red Hat Virtualization Manager : 4.0.2.4-0.1.el7ev , reported issue is still reproducible. Additionally the warning message about 'modifying kernel boot parameters' is in English now.

Comment 3 sandeep shedmake 2017-02-01 11:28:02 UTC
Could reproduce most of this bug with 4.1.0.3

Comment 4 Tomas Jelinek 2017-03-01 11:16:41 UTC

*** This bug has been marked as a duplicate of bug 1422455 ***


Note You need to log in before you can comment on or make changes to this bug.