Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355698 - [userinterface_public_648]Wrong mouse click focus
Summary: [userinterface_public_648]Wrong mouse click focus
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OKD
Classification: Red Hat
Component: Management Console
Version: 3.x
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 09:42 UTC by Yadan Pei
Modified: 2016-09-19 13:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-19 13:53:02 UTC


Attachments (Terms of Use)
ClickBlankNameFocusAboveName (deleted)
2016-07-12 09:50 UTC, Yadan Pei
no flags Details
WrongFocus (deleted)
2016-07-14 02:44 UTC, Yadan Pei
no flags Details

Description Yadan Pei 2016-07-12 09:42:35 UTC
Description of problem:
When user click Name to add env var pairs to BC/DC, very often it gives wrong focus.Reproduces on Firefox 47, Safari 9.1

Version-Release number of selected component (if applicable):
openshift v1.3.0-alpha.2-1084-g7df6638-dirty
kubernetes v1.3.0-alpha.3-599-g2746284
etcd 2.3.0+git


How reproducible:
Sometimes

Steps to Reproduce:
1. Create a project on web console
2. Click "Add to project", select "Browse Catalog" and pick php:5.5 image
3. Set Name "php" and Git Repository URL "https://github.com/openshift/cakephp-ex.git"
4. Also add Environment Variables BCone:BCvalue1, BCtwo:BCvalue2 in Build Configuration part, hit on "Create" button
5. Browse -> Builds -> select BC "php" -> click "Environment" tab
6. Click blank Name to add one pair of key/value for BC

Actual results:
6. When clicking blank Name input field, it focus on the previous Name field, you have to click again to get correct focus and type things, refer to attachment

Expected results:
6. Should focus on the input field user clicks

Additional info:
This issue also reproduces when adding env pairs to BC/DC without env vars defined

Comment 1 Yadan Pei 2016-07-12 09:50:46 UTC
Created attachment 1178823 [details]
ClickBlankNameFocusAboveName

Comment 2 Robb Hamilton 2016-07-12 12:58:25 UTC
Hi, Ya Dan.

This behavior is by design.  The clicking in the bottom row of the key value editor *adds* a new row above the row that was clicked on and sets focus on that new row.  That's because the bottom row that gets clicked on is just there as a means of adding new rows.

Thanks,
Robb.

Comment 3 bpeterse 2016-07-12 15:38:32 UTC
Correct, the intent is that there is always an additional blank row used to add new rows rather than an "add new row" button.

Comment 4 Yadan Pei 2016-07-13 02:27:37 UTC
Hi Robb, Ben

Yeah I noticed that an additional blank row is always there and clicking on this blank row will "add a new row". So in my assumption, when clicking on the last blank Name/Value, it should focus on the second row from the last(the row gets clicked) not the third row from the last(the row above the clicked row) , that's shown in screenshot.

Also sometimes when a bunch of blank row is added, randomly clicking on Name/Value(not the last additional blank row) will gave wrong focus too. 


I'm still a little confused, could you please help clarify? :)

Comment 5 Yadan Pei 2016-07-13 05:12:30 UTC
Hi Robb, Ben

Yeah I noticed that an additional blank row is always there and clicking on this blank row will "add a new row". So in my assumption, when clicking on the last blank Name/Value, it should focus on the second row from the last(the row gets clicked) not the third row from the last(the row above the clicked row) , that's shown in screenshot.

Also sometimes when a bunch of blank row is added, randomly clicking on Name/Value(not the last additional blank row) will gave wrong focus too. 


I'm still a little confused, could you please help clarify? :)

Comment 6 Yadan Pei 2016-07-13 05:12:58 UTC
Sorry about pasting twice

Comment 7 Robb Hamilton 2016-07-13 14:10:58 UTC
Ya Dan, I'm not seeing the behavior you describe in Chrome or Firefox on OS X. Are you seeing behavior similar to http://g.recordit.co/HhWad1Z0Uz.gif?

Comment 8 Yadan Pei 2016-07-14 02:44:06 UTC
Hi Robb,

Attached a gif of my testing please check

Comment 9 Yadan Pei 2016-07-14 02:44:30 UTC
Created attachment 1179560 [details]
WrongFocus

Comment 10 Yadan Pei 2016-07-14 03:02:24 UTC
This is reprocuded on Safari 9.1

Comment 11 Robb Hamilton 2016-07-14 12:42:47 UTC
Thanks, Ya Dan.  I can confirm the focus error in Safari 9.1. 

Ben, do you have bandwidth to fix?

Comment 12 bpeterse 2016-07-14 20:57:56 UTC
Lemme take a look at it

Comment 13 Yadan Pei 2016-07-18 09:10:55 UTC
Hi Robb,

Downgrade the priority since it doesn't block function, then I could accept the US

Comment 14 Robb Hamilton 2016-07-18 12:09:03 UTC
Ben fixed this issue, but the PR containing the fix hasn't merged yet.  https://github.com/openshift/origin-web-console/pull/161

Comment 15 Yadan Pei 2016-07-22 08:16:28 UTC
Launched an instance against devenv-rhel7_4639, then manually vendor origin-web-console into origin http://pastebin.test.redhat.com/394990


Tried on Firefox 47 and Safari 9.1, both works well 

Move to VERIFIED

Comment 16 Yadan Pei 2016-07-22 08:31:30 UTC
Clicking on blank Name/Value could give correct focus


Note You need to log in before you can comment on or make changes to this bug.