Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355678 - Configure bond+vlan network during anaconda interactive installation will cause fatal error.
Summary: Configure bond+vlan network during anaconda interactive installation will cau...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: ovirt-node
Classification: oVirt
Component: Installation & Update
Version: 4.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent vote
Target Milestone: ovirt-4.0.1
: ---
Assignee: Ryan Barry
QA Contact: cshao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 08:40 UTC by cshao
Modified: 2016-07-14 14:24 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-14 14:24:05 UTC
oVirt Team: Node
rule-engine: ovirt-4.0.z+
mgoldboi: planning_ack+
dfediuck: devel_ack+
cshao: testing_ack+


Attachments (Terms of Use)
bond_vlan_error (deleted)
2016-07-12 08:40 UTC, cshao
no flags Details
all log info (deleted)
2016-07-12 08:41 UTC, cshao
no flags Details
new_bond_vlan_log (deleted)
2016-07-13 03:30 UTC, cshao
no flags Details
new_bond_vlan_log (deleted)
2016-07-13 03:33 UTC, cshao
no flags Details
tmp.png (deleted)
2016-07-13 05:24 UTC, cshao
no flags Details

Description cshao 2016-07-12 08:40:45 UTC
Created attachment 1178807 [details]
bond_vlan_error

Description of problem:
Configure bond+vlan network during anaconda interactive installation will cause fatal error, user can't continue the installation and only click the "Exit installer" button.

Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.0-20160708.0.x86_64
imgbased-0.7.2-0.1.el7ev.noarch


How reproducible:
100%

Steps to Reproduce:
1. Anaconda interactive install RHVH via iso(with default ks) 
2. Enter network page.
3. Add bond network.
4. Enter Editing bond connection page-> bond tab, click add button.
5. Choose a connection type -> Ethernet -> select a device.
6. click add button again, choose a connection type -> Ethernet -> select a device.
7. Add vlan network.
8. Choose bond network as parent interface
9. Set vlan ID, vlan interface name, save.
10. Continue the installation.


Actual results:
Configure bond+vlan network during anaconda interactive installation will cause fatal error.

Expected results:
Configure bond+vlan network during anaconda interactive installation can successful.

Additional info:

Comment 1 cshao 2016-07-12 08:41:46 UTC
Created attachment 1178808 [details]
all log info

Comment 2 Anatoly Litovsky 2016-07-12 09:36:27 UTC
Please try to do it with std rhel

Comment 3 Moran Goldboim 2016-07-12 09:37:34 UTC
raising priority to urgent, since many of our customer deployment is using the exact network topology.

Comment 4 Ryan Barry 2016-07-12 17:07:05 UTC
I could not reproduce this on base RHEL.

I also could not reproduce it on RHVH-7.2-20160708.2-RHVH-x86_64-dvd1.iso

Steps taken (on both):

1. Anaconda interactive installation of RHVH
2. Enter network page
3. Add bond network
4. Click "+"
5. Choose "Bond"
6. "Add"
7. Choose a connection type -> Ethernet -> select a device.
8. Click "Add" button again, choose a connection type -> Ethernet -> select a device.
9. Click "+"
7. Choose "VLAN"
8. Choose bond network as parent interface
9. Set vlan ID, vlan interface name, save
10. Continue the installation
11. Success

Can you please attach all logs from /tmp? Or provide a test system?

Comment 5 Ryan Barry 2016-07-12 17:27:22 UTC
After answering a similar email, I wonder if you could post (in particular) program.log and ks-script*.log

Comment 6 cshao 2016-07-13 03:30:45 UTC
Created attachment 1179047 [details]
new_bond_vlan_log

> After answering a similar email, I wonder if you could post (in particular) 
> program.log and ks-script*.log

I can find program.log in /tmp folder, but there is no ks-script*.log under /var/log/, actually there was no anaconda folder generated due to installation failed.

Comment 7 cshao 2016-07-13 03:33:29 UTC
Created attachment 1179048 [details]
new_bond_vlan_log

Comment 8 Ryan Barry 2016-07-13 04:17:45 UTC
Anaconda logs are under /tmp. Can you please attach /tmp/*.log?

Comment 9 cshao 2016-07-13 05:23:40 UTC
(In reply to Ryan Barry from comment #8)
> Anaconda logs are under /tmp. Can you please attach /tmp/*.log?

All log info which I can provide has been included in #c7 "new_bond_vlan_log", it also included anaconda.log, but can't find anaconda folder under /tmp. I guess there was no anaconda folder generated due to installation failed.

Please see attachment "tmp.png"

Comment 10 cshao 2016-07-13 05:24:16 UTC
Created attachment 1179055 [details]
tmp.png

Comment 11 Ryan Barry 2016-07-13 05:30:25 UTC
Ok --

I'm surprised not to see a ks-*.log

What kickstart is being used?

I do see this in program.log:

16:37:48,817 INFO program: Running... mount -t auto -o ro /mnt/sysimage/disk.img /mnt/install/source
16:37:48,842 INFO program: mount: /mnt/sysimage/disk.img is not a block device (maybe try `-o loop'?)
16:37:48,843 DEBUG program: Return code: 32

This appears to be an error unrelated to networking, but I won't have a chance to examine the logs until the morning.

Comment 12 cshao 2016-07-13 06:29:19 UTC
(In reply to Ryan Barry from comment #11)
> Ok --
> 
> I'm surprised not to see a ks-*.log
> 
> What kickstart is being used?
I used the default ks during anaconda interactive install RHVH via iso, see bug's description step 1.

Also can reproduce this issue with below mini ks.

liveimg --url=http://10.66.10.22:8090/rhevh/rhevh7-ng-36/redhat-virtualization-host-4.0-20160708.0/redhat-virtualization-host-4.0-20160708.0.x86_64.liveimg.squashfs

> 
> I do see this in program.log:
> 
> 16:37:48,817 INFO program: Running... mount -t auto -o ro
> /mnt/sysimage/disk.img /mnt/install/source
> 16:37:48,842 INFO program: mount: /mnt/sysimage/disk.img is not a block
> device (maybe try `-o loop'?)
> 16:37:48,843 DEBUG program: Return code: 32
> 
> This appears to be an error unrelated to networking, but I won't have a
> chance to examine the logs until the morning.

Comment 13 Ryan Barry 2016-07-13 12:34:27 UTC
It's very, very difficult to tell the state of the system from the logs.

A kickstart was clearly used (rather than using the ISO as-is), and it's not clear from fetching the kickstart what state the kickstart was in last night.

[    0.000000] Command line: initrd=/images/rhevh-ngn-rhel72/initrd.img ksdevice=bootif lang=  kssendmac inst.stage2=http://download.eng.pek2.redhat.com/released/RHEL-7/7.2/Server/x86_64/os inst.ks=http://10.66.10.22:8090/rhevh/ngn/latest/ks/cshao.ks  BOOTIF=01-00-24-21-7f-b7-19 BOOT_IMAGE=/images/rhevh-ngn-rhel72/vmlinuz 

I'm not at all sure that using a RHEL stage2 is appropriate, either. Can you please try extracting LiveOS/squashfs.img from the RHV ISO and using that? The RHEL stage2 will not include our changes to Anaconda.

As of right now, there are two obvious problems with the kickstart:

"autopart --type=plain --fstype=ext4" is commented out
%post is commented out

Can you please try with the ISO? Without additional boot parameters?

Or capture the state of your kickstart and use the stage2 from the RHV ISO?

Comment 14 cshao 2016-07-14 14:24:05 UTC
Find out the reason for the fatal error.
1. The correct steps for configure bond+vlan should be:
  1) Anaconda interactive install RHVH via iso(with default ks) 
  2) Enter network page.
  3) Add bond network -> save.
  4) Enter editing bond connection page-> bond tab, click add button.
  5) Choose a connection type -> VLAN -> select a vlan nic -> set vlan name and  id 20. (This step should select VLAN but not Ethernet).
  6) click add button again, choose a connection type -> VLAN -> select another vlan nic -> set vlan name and id 20.
  7) Bond mode set -> active backup
  8) Save
  9) Bond+vlan can obtain vlan IP.

2. The original installation was over PXE, so if RHVH can't obtain a ip, then it will can't download squashfs.img, so fatal error happened.

So I'd like close this bug as WORKFORME.

Bug 1356635 can trace the new issue about can't obtain ip over bond+vlan network.

Sorry for trouble.


Note You need to log in before you can comment on or make changes to this bug.