Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355667 - Rebase rear to newer version
Summary: Rebase rear to newer version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rear
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: rc
: ---
Assignee: Jakub Mazanek
QA Contact: Tereza Cerna
Lenka Kimlickova
URL:
Whiteboard:
Depends On:
Blocks: 1380364 1393870
TreeView+ depends on / blocked
 
Reported: 2016-07-12 08:04 UTC by Jakub Mazanek
Modified: 2017-08-01 22:19 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
_rear_ rebased to version 2.0 Updated _rear_ packages that fix several bugs and add various enhancements are now available for Red Hat Enterprise Linux 7. Notable changes include: * The `Cyclic Redundancy Check` (CRC) feature is now enabled by default on the XFS file systems. Previously, "rear" ignored this change in behavior, and formatted the */boot* partition with an incompatible UUID flag. This caused the recovery process to fail. With this rebase, "rear" checks for the CRC feature, and properly preserves UUID during recovery. * Support for the `GRUB` and `GRUB2` boot loaders for IBM Power Systems architecture has been added. * Linux capabilities are now preserved if the directive `NETFS_RESTORE_CAPABILITIES` is set to the "y" option in the `/usr/share/rear/conf/default.conf` configuration file. * CIFS credentials are now preserved in rescue image. * `GRUB_SUPERUSER` and `GRUB_RESCUE_PASSWORD` directives have been dropped to avoid possible unexpected behaviour change of the `GRUB2` bootloader in the currently running system. * Documentation has been improved. * Creation of multiple backups have been enabled.
Clone Of:
: 1432421 (view as bug list)
Environment:
Last Closed: 2017-08-01 22:19:55 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2052 normal SHIPPED_LIVE rear bug fix update 2017-08-01 19:33:49 UTC

Description Jakub Mazanek 2016-07-12 08:04:35 UTC
Description of problem:
There is a new version (1.18 ) available in upstream. We would like to rebase to the newest version. Rear is written exclusively in bash. There are no known dependency issues. QA has no objections to rebase.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 8 Gratien D'haese 2017-01-19 10:34:22 UTC
Please consider to use rear-2.00 is rebase basis. It is must more stable and tested.

Comment 12 Jakub Mazanek 2017-02-23 14:56:43 UTC
We will rebase to rear-2.00

Comment 15 Tereza Cerna 2017-05-12 11:24:52 UTC
OK, reviewed and looks good. The final version is rear-2.00.

Comment 19 errata-xmlrpc 2017-08-01 22:19:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2052


Note You need to log in before you can comment on or make changes to this bug.