Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355659 - Boot guest with vhostuser server mode, QEMU prompt code level message after shutdown guest
Summary: Boot guest with vhostuser server mode, QEMU prompt code level message after s...
Keywords:
Status: CLOSED DUPLICATE of bug 1354090
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Ademar Reis
QA Contact: Pei Zhang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 07:41 UTC by Pei Zhang
Modified: 2016-07-12 20:57 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-12 16:10:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Pei Zhang 2016-07-12 07:41:31 UTC
Description of problem:
This is in rhel7.2 Z. Boot a guest with vhostuser server mode, QEMU will prompt code level warning messages after shutdown guest. 

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-2.3.0-31.el7_2.18.x86_64

How reproducible:
10%

Steps to Reproduce:
1. Run a slirp/vlan in a background process
# /usr/libexec/qemu-kvm \
-net none \
-net socket,vlan=0,udp=localhost:4444,localaddr=localhost:5555 \
-net user,vlan=0

2. Start qemu with vhost-user as server mode
# /usr/libexec/qemu-kvm  -m 1024 -smp 2 \
-object memory-backend-file,id=mem,size=1024M,mem-path=/dev/hugepages,share=on \
-numa node,memdev=mem -mem-prealloc \
-chardev socket,id=char0,path=/tmp/vubr.sock,server \
-netdev type=vhost-user,id=mynet1,chardev=char0,vhostforce \
-device virtio-net-pci,netdev=mynet1,mac=54:52:00:1a:2c:01 \
/home/pezhang/rhel7.3.qcow2 \
-monitor stdio \
-vga std -vnc :10 \

3. Start vubr as vhostuser client
# ./vhost-user-bridge -c

4. Shutdown guest, qemu will print below messages.
(qemu) system_powerdown 
or
in guest:
# shutdown -h now 

(qemu) 
(process:16842): GLib-CRITICAL **: g_io_channel_write_chars: assertion 'channel != NULL' failed

(process:16842): GLib-CRITICAL **: g_io_channel_write_chars: assertion 'channel != NULL' failed

Actual results:
Qemu quit with printing code level warning messages. Seems it doesn't quit well.
(process:14946): GLib-CRITICAL **: g_io_channel_write_chars: assertion 'channel->is_writeable' failed

Expected results:
Qemu should quit without warning or error info.

Additional info:
1. gdb info
(qemu) 
(process:14946): GLib-CRITICAL **: g_io_channel_write_chars: assertion 'channel->is_writeable' failed

(process:14946): GLib-CRITICAL **: g_io_channel_write_chars: assertion 'channel->is_writeable' failed
(gdb) bt
No stack.

2. Previous version qemu-kvm-rhev-2.3.0-31.el7_2.17.x86_64 doesn't hit this issue.

3. This bug is found during verifying Bug 1351892 - vhost-user: A socket file is not deleted after VM's port is detached.

Comment 3 Ademar Reis 2016-07-12 16:10:56 UTC

*** This bug has been marked as a duplicate of bug 1354090 ***


Note You need to log in before you can comment on or make changes to this bug.