Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355637 - listoragemgmt: local-disk-list should not require --uri parameter
Summary: listoragemgmt: local-disk-list should not require --uri parameter
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libstoragemgmt
Version: 7.3
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Gris Ge
QA Contact: Bruno Goncalves
URL:
Whiteboard:
Depends On:
Blocks: 1304953
TreeView+ depends on / blocked
 
Reported: 2016-07-12 07:00 UTC by Bruno Goncalves
Modified: 2016-11-04 06:10 UTC (History)
0 users

Fixed In Version: libstoragemgmt-1.3.2-7.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 06:10:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:2415 normal SHIPPED_LIVE libstoragemgmt bug fix update 2016-11-03 13:57:59 UTC

Description Bruno Goncalves 2016-07-12 07:00:25 UTC
Description of problem:
Trying to list local disks using lsmcli  local-disk-list should not require --uri

Version-Release number of selected component (if applicable):
libstoragemgmt-1.3.2-6.el7

How reproducible:
100%

Steps to Reproduce:
1.lsmcli  local-disk-list
lsmcli: error: --uri missing or export LSMCLI_URI

Actual results:
lsmcli: error: --uri missing or export LSMCLI_URI

Expected results:
List all local dissk

Additional info:
Using lsmcli  ldl, works well

# lsmcli  ldl
Path     | SCSI VPD 0x83    | Revolutions Per Minute | Link Type
----------------------------------------------------------------
/dev/sda | 50014ee05952cb5a | 7200                   | PATA/SATA

Comment 1 Gris Ge 2016-07-12 07:13:50 UTC
Upstream patch is:
https://github.com/libstorage/libstoragemgmt/pull/165

Comment 4 Bruno Goncalves 2016-07-14 09:58:48 UTC
It works well on libstoragemgmt-1.3.2-7.el7

# lsmcli local-disk-list
Path     | SCSI VPD 0x83                    | Revolutions Per Minute | Link Type
--------------------------------------------------------------------------------
/dev/sda | 50014ee05952cb5a                 | 7200                   | PATA/SATA
/dev/sdc | 6001405dfae8f1ba057424ba7498cacd | No Support             | FC       
/dev/sdb | 6001405dfae8f1ba057424ba7498cacd | No Support             | FC       


# lsmcli    ldl
Path     | SCSI VPD 0x83                    | Revolutions Per Minute | Link Type
--------------------------------------------------------------------------------
/dev/sda | 50014ee05952cb5a                 | 7200                   | PATA/SATA
/dev/sdc | 6001405dfae8f1ba057424ba7498cacd | No Support             | FC       
/dev/sdb | 6001405dfae8f1ba057424ba7498cacd | No Support             | FC

Comment 6 errata-xmlrpc 2016-11-04 06:10:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2415.html


Note You need to log in before you can comment on or make changes to this bug.