Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355634 - Allow to cancel all builds going into my project
Summary: Allow to cancel all builds going into my project
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Copr
Classification: Community
Component: backend
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: clime
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 06:53 UTC by Vít Ondruch
Modified: 2016-07-12 17:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-12 17:23:12 UTC


Attachments (Terms of Use)

Description Vít Ondruch 2016-07-12 06:53:46 UTC
Description of problem:
I gave permission to my project [1] to some other user. But I'd say I should be able to cancel their builds [2], since I am owner of the repo, but I can't do that:

$ copr-cli cancel 377466

Something went wrong:
Error: Cannot cancel build 377466


while I can cancel my builds just fine.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
I cannot cancel builds of other  people.


Expected results:
I can cancel builds of other people.


Additional info:


[1] https://copr.fedorainfracloud.org/coprs/vondruch/ror5/
[2] https://copr.fedorainfracloud.org/coprs/vondruch/ror5/build/377466/

Comment 1 clime 2016-07-12 12:45:00 UTC
Hello Vít,

this message is usually printed out if the build is already in running (or later) phase and you try to cancel it. Isn't it possible that this was the real cause of the issue? Because the code looks alright and the issue cannot be reproduced otherwise.


Note You need to log in before you can comment on or make changes to this bug.