Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355617 - Node info spill out of the box on cockpit UI via Internet Explorer 11
Summary: Node info spill out of the box on cockpit UI via Internet Explorer 11
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: cockpit-ovirt
Version: 4.0.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.0.2
: 4.0.0
Assignee: Ryan Barry
QA Contact: cshao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 05:47 UTC by cshao
Modified: 2016-08-23 20:59 UTC (History)
14 users (show)

Fixed In Version: cockpit-ovirt-0.10.6-1.3.1.el7ev
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 20:59:06 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
spill-out-IE11 (deleted)
2016-07-12 05:47 UTC, cshao
no flags Details
spill-out-IE11-all-log (deleted)
2016-07-12 05:49 UTC, cshao
no flags Details
IE.png (deleted)
2016-07-28 06:42 UTC, cshao
no flags Details
firefox.png (deleted)
2016-07-28 06:42 UTC, cshao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:1679 normal SHIPPED_LIVE New package: cockpit-ovirt for RHV 4.0 2016-09-02 21:35:29 UTC
oVirt gerrit 60659 master MERGED dashboard: fix the health modal, fix bootloader on IE11 2016-07-13 15:09:53 UTC
oVirt gerrit 60675 ovirt-4.0 MERGED dashboard: fix the health modal, fix bootloader on IE11 2016-07-13 15:11:31 UTC

Description cshao 2016-07-12 05:47:21 UTC
Created attachment 1178679 [details]
spill-out-IE11

Description of problem:
Node info spill out of the box on cockpit UI via Internet Explorer 11

Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.0-20160708.0.x86_64 
redhat-release-virtualization-host-4.0-0.13.el7.x86_64
imgbased-0.7.2-0.1.el7ev.noarch
cockpit-ovirt-dashboard-0.10.6-1.2.0.el7ev.noarch
windows Internet Explorer 11 (version:11.0.9600.17843)


How reproducible:
100%

Steps to Reproduce:
1. Install RHVH via iso(with default ks)
2. Login cockpit via IE 11.
3. Switch to virtualization-> dashboard tab.
4. Click information button, expand all info.

Actual results:
Node info spill out of the box on cockpit UI via Internet Explorer 11


Expected results:
No spill out on cockpit UI via Internet Explorer 11.

Additional info:
No such issue on firefox & chrome.

Comment 1 cshao 2016-07-12 05:49:18 UTC
Created attachment 1178680 [details]
spill-out-IE11-all-log

Comment 3 cshao 2016-07-28 06:27:54 UTC
Test version:
redhat-virtualization-host-4.0-20160727.1
cockpit-ovirt-dashboard-0.10.6-1.3.3.el7ev.noarch
cockpit-0.114-2.el7.x86_64

Test steps:
1. Install RHVH via PXE.
2. Login cockpit via IE 11/Firefox/Chrome.
3. Switch to virtualization-> dashboard tab.
4. Click information button, expand all info.

Test result:
1. Inter Explore 11:
The original issue "spill out" was gone, but the new issue (overlap) is coming, please see attachment "IE.png" for more details.

2. FireFox:
Status Icons of node health info are overlapped.

3. Chrome:
Node health info can show correctly in chrome.

In any case, the original issue was gone, I'd like verify this bug and re-open a new one to trace the overlap issue.

Comment 4 cshao 2016-07-28 06:42:16 UTC
Created attachment 1184885 [details]
IE.png

Comment 5 cshao 2016-07-28 06:42:42 UTC
Created attachment 1184887 [details]
firefox.png

Comment 6 cshao 2016-07-28 07:24:10 UTC
(In reply to shaochen from comment #3)
> Test version:
> redhat-virtualization-host-4.0-20160727.1
> cockpit-ovirt-dashboard-0.10.6-1.3.3.el7ev.noarch
> cockpit-0.114-2.el7.x86_64
> 
> Test steps:
> 1. Install RHVH via PXE.
> 2. Login cockpit via IE 11/Firefox/Chrome.
> 3. Switch to virtualization-> dashboard tab.
> 4. Click information button, expand all info.
> 
> Test result:
> 1. Inter Explore 11:
> The original issue "spill out" was gone, but the new issue (overlap) is
> coming, please see attachment "IE.png" for more details.
> 
> 2. FireFox:
> Status Icons of node health info are overlapped.
> 
> 3. Chrome:
> Node health info can show correctly in chrome.
> 
> In any case, the original issue was gone, I'd like verify this bug and
> re-open a new one to trace the overlap issue.

Bug 1361006 can trace the new issue.

Comment 8 errata-xmlrpc 2016-08-23 20:59:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1679.html


Note You need to log in before you can comment on or make changes to this bug.