Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355610 - Fix timing issue in tests/bugs/glusterd/bug-963541.t
Summary: Fix timing issue in tests/bugs/glusterd/bug-963541.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: 3.8.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Satish Mohan
QA Contact:
URL:
Whiteboard:
Depends On: 1354372 1375049
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 05:07 UTC by Sakshi
Modified: 2016-09-12 04:26 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8.2
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1354372
Environment:
Last Closed: 2016-08-12 09:47:17 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sakshi 2016-07-12 05:07:06 UTC
+++ This bug was initially created as a clone of Bug #1354372 +++

Description of problem:
Start and stop rebalance, but the stop command fails as by that time the rebalance process has not come up.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:


Additional info:
RCA: on starting rebalance, the process had not come up because glusterd spawns it with nowait from runner interface. So the rebalance stop issued fails

--- Additional comment from Vijay Bellur on 2016-07-11 04:07:44 EDT ---

REVIEW: http://review.gluster.org/14885 (tests: fix rebalance timing issue) posted (#1) for review on master by Sakshi Bansal

--- Additional comment from Vijay Bellur on 2016-07-11 10:05:01 EDT ---

COMMIT: http://review.gluster.org/14885 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit bfbadab0d65f38d2719ceb4d5c9144377db9d4d5
Author: Sakshi Bansal <sabansal@redhat.com>
Date:   Mon Jul 11 13:34:28 2016 +0530

    tests: fix rebalance timing issue
    
    With a start and stop rebalance, the stop command may fail
    as by that time the rebalance process may not come up.
    Using the rebalance status commmand to ensure that the rebalance
    process is up before stoping rebalance.
    
    Change-Id: I3d5123cd5dfabde2720428455b257d11b980ce21
    BUG: 1354372
    Signed-off-by: Sakshi Bansal <sabansal@redhat.com>
    Reviewed-on: http://review.gluster.org/14885
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 1 Vijay Bellur 2016-07-12 05:11:09 UTC
REVIEW: http://review.gluster.org/14897 (tests: fix rebalance timing issue) posted (#1) for review on release-3.8 by Sakshi Bansal

Comment 2 Vijay Bellur 2016-07-21 11:04:39 UTC
COMMIT: http://review.gluster.org/14897 committed in release-3.8 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 54e7397505f0a6b218ab70415420371a5755ef0d
Author: Sakshi Bansal <sabansal@redhat.com>
Date:   Mon Jul 11 13:34:28 2016 +0530

    tests: fix rebalance timing issue
    
    With a start and stop rebalance, the stop command may fail
    as by that time the rebalance process may not come up.
    Using the rebalance status commmand to ensure that the rebalance
    process is up before stoping rebalance.
    
    Backport of http://review.gluster.org/14885
    
    > Change-Id: I3d5123cd5dfabde2720428455b257d11b980ce21
    > BUG: 1354372
    > Signed-off-by: Sakshi Bansal <sabansal@redhat.com>
    > Reviewed-on: http://review.gluster.org/14885
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    
    Change-Id: I3d5123cd5dfabde2720428455b257d11b980ce21
    BUG: 1355610
    Signed-off-by: Sakshi Bansal <sabansal@redhat.com>
    Reviewed-on: http://review.gluster.org/14897
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 5 Niels de Vos 2016-08-12 09:47:17 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.2, please open a new bug report.

glusterfs-3.8.2 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://www.gluster.org/pipermail/announce/2016-August/000058.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.