Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355604 - afr coverity fixes
Summary: afr coverity fixes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravishankar N
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1360549 1360556
TreeView+ depends on / blocked
 
Reported: 2016-07-12 04:50 UTC by Ravishankar N
Modified: 2017-03-27 18:16 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.9.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1360549 1360556 (view as bug list)
Environment:
Last Closed: 2017-03-27 18:16:04 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Ravishankar N 2016-07-12 04:50:42 UTC
Description of problem:

Fixing some of the afr bugs reported by coverity that was run on  downstream code (RHGS 3.1.3). The entire report of the run is attached herewith.

Comment 1 Vijay Bellur 2016-07-12 04:52:40 UTC
REVIEW: http://review.gluster.org/14895 (afr: some coverity fixes) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 2 Vijay Bellur 2016-07-12 14:19:46 UTC
REVIEW: http://review.gluster.org/14895 (afr: some coverity fixes) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 3 Vijay Bellur 2016-07-12 15:45:18 UTC
REVIEW: http://review.gluster.org/14895 (afr: some coverity fixes) posted (#3) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 4 Vijay Bellur 2016-07-15 09:57:04 UTC
REVIEW: http://review.gluster.org/14895 (afr: some coverity fixes) posted (#4) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 5 Vijay Bellur 2016-07-18 08:48:36 UTC
REVIEW: http://review.gluster.org/14895 (afr: some coverity fixes) posted (#5) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 6 Vijay Bellur 2016-07-18 11:31:17 UTC
REVIEW: http://review.gluster.org/14895 (afr: some coverity fixes) posted (#6) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 7 Vijay Bellur 2016-07-23 05:18:00 UTC
REVIEW: http://review.gluster.org/14895 (afr: some coverity fixes) posted (#7) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 8 Vijay Bellur 2016-07-25 14:20:16 UTC
REVIEW: http://review.gluster.org/14895 (afr: some coverity fixes) posted (#8) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 9 Vijay Bellur 2016-07-26 08:37:10 UTC
REVIEW: http://review.gluster.org/14895 (afr: some coverity fixes) posted (#9) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 10 Vijay Bellur 2016-07-26 10:28:52 UTC
REVIEW: http://review.gluster.org/14895 (afr: some coverity fixes) posted (#10) for review on master by Ravishankar N (ravishankar@redhat.com)

Comment 11 Vijay Bellur 2016-07-26 17:06:56 UTC
COMMIT: http://review.gluster.org/14895 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit d1e2054974c5933771fe0e5626e2cd04bccc757a
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Tue Jul 12 10:07:48 2016 +0530

    afr: some coverity fixes
    
    Thanks to Krutika for a cleaner way to track inode refs in
    afr_set_split_brain_choice().
    
    Change-Id: I2d968d05b815ad764b7e3f8aa9ad95a792b3c1df
    BUG: 1355604
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/14895
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 12 Shyamsundar 2017-03-27 18:16:04 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.