Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1355597 - rhel-osp-director: overcloud deployment fails [glance-manage db_sync]: Failed to call refresh: glance-manage --config-file /etc/glance/glance-registry.conf db_sync returned 1 instead of one of [0]
Summary: rhel-osp-director: overcloud deployment fails [glance-manage db_sync]: Faile...
Keywords:
Status: CLOSED DUPLICATE of bug 1348188
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 10.0 (Newton)
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Angus Thomas
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-12 03:15 UTC by Alexander Chuzhoy
Modified: 2016-07-12 16:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-12 16:16:27 UTC


Attachments (Terms of Use)
heat logs (deleted)
2016-07-12 03:31 UTC, Alexander Chuzhoy
no flags Details

Description Alexander Chuzhoy 2016-07-12 03:15:10 UTC
rhel-osp-director:  overcloud deployment fails [glance-manage db_sync]: Failed to call refresh: glance-manage --config-file /etc/glance/glance-registry.conf db_sync returned 1 instead of one of [0]

Environment:
instack-undercloud-5.0.0-0.20160701050805.1ffeb4b.el7ost.noarch
openstack-tripleo-heat-templates-5.0.0-0.20160705210328.0fbe987.el7ost.noarch
openstack-puppet-modules-9.0.0-0.20160630235319.8c758d6.el7ost.noarch



Steps to reproduce:
Attempt to deploy overcloud with:


Result: 
The overcloud deployment fails with:

Notice: Finished catalog run in 111.92 seconds
", "deploy_stderr": "Warning: Scope(Class[Neutron]): The neutron::network_device_mtu parameter is deprecated, use neutron::global_physnet_mtu instead.
Warning: Variable access via 'notification_email_to' is deprecated. Use '@notification_email_to' instead. template[/etc/puppet/modules/keepalived/templates/global_config.erb]:3
 (at /etc/puppet/modules/keepalived/templates/global_config.erb:3:in `block in result')
Warning: notify is a metaparam; this value will inherit to all contained resources in the keepalived::instance definition
Warning: Scope(Class[Tripleo::Profile::Base::Nova]): Overriding memcached_servers from puppet-tripleo until 325983 lands.
Warning: Scope(Class[Mongodb::Server]): Replset specified, but no replset_members or replset_config provided.
Warning: Scope(Haproxy::Config[haproxy]): haproxy: The $merge_options parameter will default to true in the next major release. Please review the documentation regarding the implications.
160712 3:03:53 [Warning] option 'open_files_limit': unsigned value 18446744073709551615 adjusted to 4294967295
Warning: Unexpected line: Ring file /etc/swift/object.ring.gz not found, probably it hasn't been written yet
Warning: Unexpected line: Ring file /etc/swift/container.ring.gz not found, probably it hasn't been written yet
Warning: Unexpected line: Ring file /etc/swift/account.ring.gz not found, probably it hasn't been written yet
Error: /Stage[main]/Glance::Db::Sync/Exec[glance-manage db_sync]: Failed to call refresh: glance-manage --config-file /etc/glance/glance-registry.conf db_sync returned 1 instead of one of [0]
Error: /Stage[main]/Glance::Db::Sync/Exec[glance-manage db_sync]: glance-manage --config-file /etc/glance/glance-registry.conf db_sync returned 1 instead of one of [0]
Error: /Stage[main]/Nova::Db::Sync/Exec[nova-db-sync]: Failed to call refresh: /usr/bin/nova-manage db sync returned 1 instead of one of [0]
Error: /Stage[main]/Nova::Db::Sync/Exec[nova-db-sync]: /usr/bin/nova-manage db sync returned 1 instead of one of [0]
Error: /Stage[main]/Keystone::Db::Sync/Exec[keystone-manage db_sync]: Failed to call refresh: keystone-manage db_sync returned 1 instead of one of [0]
Error: /Stage[main]/Keystone::Db::Sync/Exec[keystone-manage db_sync]: keystone-manage db_sync returned 1 instead of one of [0]
Error: /Stage[main]/Heat::Db::Sync/Exec[heat-dbsync]: Failed to call refresh: heat-manage --config-file /etc/heat/heat.conf db_sync returned 1 instead of one of [0]
Error: /Stage[main]/Heat::Db::Sync/Exec[heat-dbsync]: heat-manage --config-file /etc/heat/heat.conf db_sync returned 1 instead of one of [0]


Expected result:
successful deployment

Comment 2 Alexander Chuzhoy 2016-07-12 03:16:42 UTC
Deployment command:
openstack overcloud deploy --templates --control-scale 3 --compute-scale 1 --neutron-network-type vxlan --neutron-tunnel-types vxlan --ntp-server clock.redhat.com --timeout 90 -e /usr/share/openstack-tripleo-heat-templates/environments/storage-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e network-environment.yaml --ceph-storage-scale 1


network-environment.yaml:
[stack@instack ~]$ cat network-environment.yaml
resource_registry:
  OS::TripleO::BlockStorage::Net::SoftwareConfig: /home/stack/nic-configs/cinder-storage.yaml
  OS::TripleO::Compute::Net::SoftwareConfig: /home/stack/nic-configs/compute.yaml
  OS::TripleO::Controller::Net::SoftwareConfig: /home/stack/nic-configs/controller.yaml
  OS::TripleO::ObjectStorage::Net::SoftwareConfig: /home/stack/nic-configs/swift-storage.yaml
  OS::TripleO::CephStorage::Net::SoftwareConfig: /home/stack/nic-configs/ceph-storage.yaml


parameter_defaults:
  # Customize all these values to match the local environment
  NeutronExternalNetworkBridge: "''"
parameter_defaults:
  InternalApiNetCidr: 192.168.100.0/24
  StorageNetCidr: 192.168.110.0/24
  StorageMgmtNetCidr: 192.168.120.0/24
  TenantNetCidr: 192.168.150.0/24
  ExternalNetCidr: 192.168.200.0/24
  InternalApiAllocationPools: [{'start': '192.168.100.10', 'end': '192.168.100.200'}]
  StorageAllocationPools: [{'start': '192.168.110.10', 'end': '192.168.110.200'}]
  StorageMgmtAllocationPools: [{'start': '192.168.120.10', 'end': '192.168.120.200'}]
  TenantAllocationPools: [{'start': '192.168.150.10', 'end': '192.168.150.200'}]
  # Use an External allocation pool which will leave room for floating IPs
  ExternalAllocationPools: [{'start': '192.168.200.180', 'end': '192.168.200.200'}]
  # Set to the router gateway on the external network
  ExternalInterfaceDefaultRoute: 192.168.200.1
  DnsServers: ["10.16.36.29"]
  ControlPlaneSubnetCidr: "24"
  ControlPlaneDefaultRoute: 192.0.2.1
  EC2MetadataIp: 192.0.2.1

Comment 3 Alexander Chuzhoy 2016-07-12 03:31:33 UTC
Created attachment 1178638 [details]
heat logs

Comment 5 Marius Cornea 2016-07-12 07:30:55 UTC
Hi Sasha,

I suspect this is caused by pacemaker not being enabled by default right now: BZ#1348188

Comment 6 Alexander Chuzhoy 2016-07-12 16:16:27 UTC

*** This bug has been marked as a duplicate of bug 1348188 ***


Note You need to log in before you can comment on or make changes to this bug.