Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354688 - libxcb-1.12-1.fc25 breaks compilation of xine-lib
Summary: libxcb-1.12-1.fc25 breaks compilation of xine-lib
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: libxcb
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 23:40 UTC by Sergio Monteiro Basto
Modified: 2016-07-25 03:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-25 03:37:33 UTC


Attachments (Terms of Use)

Description Sergio Monteiro Basto 2016-07-11 23:40:33 UTC
Description of problem:

with mock -r fedora-rawhide-x86_64  --shell 

<mock-chroot> sh-4.3# pkg-config --libs xcb-shape
-lxcb-shape
<mock-chroot> sh-4.3# pkg-config --libs xcb-shm
-lxcb-shm
<mock-chroot> sh-4.3# pkg-config --libs xcb-xv
-lxcb-xv
<mock-chroot> sh-4.3# 

with mock -r fedora-23-x86_64  --shell

<mock-chroot> sh-4.3#  pkg-config --libs xcb-shape
-lxcb-shape -lxcb 
<mock-chroot> sh-4.3# pkg-config --libs xcb-shm
-lxcb-shm -lxcb 
<mock-chroot> sh-4.3# pkg-config --libs xcb-xv
-lxcb-xv -lxcb-shm -lxcb 



Version-Release number of selected component (if applicable):
libxcb-1.12-1.fc25

How reproducible:
building xine-lib in rawhide, breaks compilation because it misses -lxcb and  -lxcb-shm when compiling something which use xcb-xv for example.

Comment 1 Sergio Monteiro Basto 2016-07-12 00:07:11 UTC
On Fedora 24 
cat /usr/lib64/pkgconfig/xcb-xv.pc 
(...)
Name: XCB Xv
Description: XCB Xv Extension
Version: 1.11.1
Requires: xcb xcb-shm
Libs: -L${libdir} -lxcb-xv
Cflags: -I${includedir}

when on rawhide have :
Requires.private: xcb xcb-shm


So googling I guess this happens because : 

https://lists.freedesktop.org/archives/xcb/2014-September/009871.html

https://lists.freedesktop.org/archives/xcb/2014-August/009654.html

Comment 2 Sergio Monteiro Basto 2016-07-13 00:09:38 UTC
you can check xine-lib build here :
http://koji.rpmfusion.org/koji/taskinfo?taskID=7167 

on http://koji.rpmfusion.org/kojifiles/work/tasks/7167/7167/build.log it ends with: 
gcc -O3  -ffast-math -fexpensive-optimizations  -fvisibility=hidden   -I/usr/include/ffmpeg   -pipe  -Wall -Wformat=2 -Wno-format-zero-length -Wmissing-format-attribute -Werror-implicit-function-declaration -Wstrict-aliasing=2 -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes -Wwrite-strings -Wpointer-arith -g -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic -Wall -Wchar-subscripts -Wnested-externs -Wcast-align -Wmissing-declarations -Wmissing-prototypes -Wmissing-format-attribute -Wno-pointer-sign -Wformat=2 -Wno-format-zero-length -Wformat-security -Wstrict-aliasing=2 -Werror=implicit-function-declaration -Wl,-z,defs -Wl,--gc-sections -avoid-version -module -g -Wl,-z,relro -specs=/usr/lib/rpm/redhat/redhat-hardened-ld -o xineplug_vo_out_xcbshm.la -rpath /usr/lib64/xine/plugins/2.5 xineplug_vo_out_xcbshm_la-video_out_xcbshm.lo xineplug_vo_out_xcbshm_la-xcbosd.lo libyuv2rgb.la ../../src/xine-engine/libxine.la  -lavutil -pthread -lxcb-shape -lxcb-shm

and is missing -lxcb 

any tip ? 

Thanks

Comment 3 Sergio Monteiro Basto 2016-07-25 03:37:33 UTC
Found a fix here: https://bugs.xine-project.org/show_bug.cgi?id=573


Note You need to log in before you can comment on or make changes to this bug.