Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354684 - Unicode speechmarks in Organization name accepted, but prevent content host registration
Summary: Unicode speechmarks in Organization name accepted, but prevent content host r...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Organizations and Locations
Version: 6.2.0
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 22:58 UTC by Dan Hawke
Modified: 2017-11-15 14:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-15 14:40:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dan Hawke 2016-07-11 22:58:02 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install satellite with a command like:
satellite-installer --scenario satellite -v \
--foreman-initial-organization “OSSLab” \
--foreman-initial-location “Auckland” \
--foreman-admin-password testpassword \
--capsule-puppet true \
--foreman-proxy-puppetca true \
--foreman-proxy-tftp true \
--enable-foreman-plugin-discovery
(Note the Unicode ”'s rather than "'s)
2. Go to Content Hosts > Register Content Host
3. See subscription-manager command
4. Try correcting Organization name to remove unicode (e.g. rename to OSSLab)
5. Check subscription-manager command (still not fixed)

Actual results:
Command shows UUID:
subscription-manager register --org="cf88331d-cd78-4fac-b75c-05ba6a255b5f" --activationkey="<Activation Key Name>"


Expected results:
Should show a valid registration command

Additional info:

Comment 2 Marek Hulan 2017-11-15 14:40:51 UTC
I believe this is a feature of Satellite. The organization label can't be changed later, only it's name can be changed. The label is normally derived from the name but if it contains unsupported characters for label, it fallbacks to this UUID. The only solution is to remove the organization and create a new one. If you create organization in already installed Satellite, you can specify your own label, but it's not possible for the installer.

I'm closing as not a bug, please reopen or let me know if I misunderstood the request or you have further questions. Thank you.


Note You need to log in before you can comment on or make changes to this bug.