Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354663 - Documentation for rsyslog centralized logging contains typos
Summary: Documentation for rsyslog centralized logging contains typos
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 5.0 (RHEL 7)
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
: ---
Assignee: RHOS Documentation Team
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
: 1421233 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 22:03 UTC by David Mulford
Modified: 2017-07-17 15:42 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Build Name: 22465, Installation and Configuration Guide-3-1 Build Date: 13-02-2014 15:49:11 Topic ID: 15932-446841 [Specified]
Last Closed: 2017-07-17 15:42:56 UTC


Attachments (Terms of Use)
Screen shot of documentation with call outs. (deleted)
2016-07-11 22:03 UTC, David Mulford
no flags Details

Description David Mulford 2016-07-11 22:03:08 UTC
Created attachment 1178549 [details]
Screen shot of documentation with call outs.

Title: Configuring rsyslog on the Centralized Logging Server

Describe the issue:
Steps 1 and 3 contain typos that need to be fixed.

Suggestions for improvement:

For step 1, the documentation gives the following command to add the rsyslog port 514 through SELinux.

  # semanage -a -t syslogd_port_t -p udp 514

However, the "port" command is missing there, and the full command needs to say:

  # semanage port -a -t syslogd_port_t -p udp 514

For step 3, the documentation lists the following /etc/rsyslog.conf entries.

  $template TmplAuth, "/var/log/%HOSTNAME%/%PROGRAMNAME%.log" 

  authpriv.*   ?TmplAuth
  *.info,mail.none,authpriv.none,cron.none   ?TmplMsg

The last time contains ?TmplMsg, which creates an error when rsyslog parses the config file. Changing ?TmplMsg to ?TmplAuth fixes the issue. Here is the correct config:

  $template TmplAuth, "/var/log/%HOSTNAME%/%PROGRAMNAME%.log" 

  authpriv.*   ?TmplAuth
  *.info,mail.none,authpriv.none,cron.none   ?TmplAuth


Additional information:

I've added a screen shot highlighting the sections mentioned above.

Here is a link to the document:
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/3/html/Installation_and_Configuration_Guide/Configuring_the_rsyslog_Server.html

Comment 2 Lucy Bopf 2017-02-16 01:48:47 UTC
*** Bug 1421233 has been marked as a duplicate of this bug. ***

Comment 3 Lars Kellogg-Stedman 2017-07-17 15:42:56 UTC
The centralized logging solution we delivered in OSP11 does not use rsyslog.


Note You need to log in before you can comment on or make changes to this bug.