Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354657 - [RFE]Need to support Ceph 1.3.2 or Ceph 2.0 for OSP10
Summary: [RFE]Need to support Ceph 1.3.2 or Ceph 2.0 for OSP10
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M3
: 10.0 (Newton)
Assignee: Giulio Fidente
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 21:29 UTC by Jeff Brown
Modified: 2016-09-12 20:40 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-09-12 20:40:26 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jeff Brown 2016-07-11 21:29:32 UTC
Description of problem:

OSP10 needs to support download selection of either Ceph 1.3.2 or Ceph 2.0.  This support is not built into the deployment today and must be added.  Both versoin of the SW must be included in the RDO overcloud SW package.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 seb 2016-07-19 13:33:27 UTC
As per our discussions, it looks like we are going to end up with 2 different images for this.
Later when we will have containers, we won't have this problem anymore :), we are just not there yet :)

Comment 3 seb 2016-07-28 13:14:59 UTC
Gulio, any updates on this one?

Comment 4 Giulio Fidente 2016-08-02 12:40:41 UTC
We'll need to do some work in puppet-ceph to make sure the master version (newton branch) is able to configure ceph/hammer

Currently only the mitaka branch of puppet-ceph can deploy ceph/hammer

Comment 5 Jeff Brown 2016-08-02 19:29:42 UTC
We are using this bug to track the Ceph 2.0 support for OSP10.  We originally had another bug for this, but it was closed on 7/22. (Bz1354648).  This Bz was orginally intended as the selection capability of Ceph 1.3.2 or Ceph 2.0. That capability will be gotten with different images for OSP10, which are specific to your Ceph revision needs. This Bz is now collapsed to track both Ceph 2.0 support and the Ceph revision selection capability.


Note You need to log in before you can comment on or make changes to this bug.