Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354643 - Installation of webui2 on fresh Shinken setup fails due to missing directory
Summary: Installation of webui2 on fresh Shinken setup fails due to missing directory
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: shinken
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Hannequin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 20:14 UTC by Uwe Sauter
Modified: 2016-10-08 13:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-10-08 13:37:10 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github shinken-monitoring mod-webui issues 521 None None None 2016-07-11 20:14:43 UTC

Description Uwe Sauter 2016-07-11 20:14:43 UTC
Description of problem:
Trying to install the web user interface for Shinken it fails due to a missing directory. Developer tells me this is a packaging issue.

Version-Release number of selected component (if applicable):
- up-to-date Fedora Server 24 x86_64
- shinken-2.4.3-1.fc24.noarch

How reproducible:
Everytime


Steps to Reproduce:
1. Install dependencies of Shinken & WebUI2:
# dnf install -y python-bottle mongodb mongodb-server python-pymongo
2. Start Mongod
# systemctl enable mongod; systemctl start mongod
3. Install Shinken:
# dnf install -y shinken*
4. Initialize shinken
# shinken --init
5. Install WebUI2:
# shinken install webui2

Actual results:
[root@fedora24 ~]# shinken install webui2
Grabbing : webui2
[1468267687] ERROR: [Shinken] The installation directory /var/lib/shinken/doc is missing!

Expected results:
[root@fedora24 ~]# shinken install webui2
Grabbing : webui2
OK webui2

Additional info:
Directory "/var/lib/shinken/doc" needs to be included in the shinken package - currently:

# dnf info shinken
Installed Packages
Name        : shinken
Arch        : noarch
Epoch       : 0
Version     : 2.4.3
Release     : 1.fc24
Size        : 3.0 M
Repo        : @System
From repo   : updates
Summary     : Python Monitoring tool
URL         : http://www.shinken-monitoring.org

Comment 1 Uwe Sauter 2016-07-11 20:15:25 UTC
This does also apply to the packages in EPEL for CentOS 7.

Comment 2 David Hannequin 2016-10-08 13:37:10 UTC
Hi,

Sorry for the delay but it fix in version 2.4.3-2.

Thanks for reporting.


Note You need to log in before you can comment on or make changes to this bug.