Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354640 - [RFE] GlusterFS PV should not use Endpoints since they are per project
Summary: [RFE] GlusterFS PV should not use Endpoints since they are per project
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: heketi
Version: rhgs-3.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: CNS 3.4
Assignee: Humble Chirammal
QA Contact: Prasanth
URL:
Whiteboard:
Depends On:
Blocks: 1385245
TreeView+ depends on / blocked
 
Reported: 2016-07-11 20:05 UTC by Luis Pabón
Modified: 2017-03-13 11:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Previously, the 'endpoints' and 'service' on the 'projects/namespaces' had to be created to use Red Hat Gluster Storage persistent volumes. With this release, when the volumes are dynamically provisioned by the gluster provisioner, the subjected 'endpoint' and 'service' are auto created and the user will be able to use these persistent volumes.
Clone Of:
Environment:
Last Closed: 2017-01-18 21:56:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:0148 normal SHIPPED_LIVE heketi bug fix and enhancement update 2017-01-19 02:53:24 UTC

Description Luis Pabón 2016-07-11 20:05:23 UTC
Description of problem:

== This is not a Heketi bug.  This is registered here to track the upstream GlusterFS adapter bug.  We should move this to an 'rhgs-ose' component when available ==

We thought at first that we could create a pool of GlusterFS PVs available for any namespace PVC to bind to. The issue is that GlusterFS adapter requires the PV to refer to an Endpoint, and endpoints are per namespace only, even though PVs are cluster wide.

The usability of this model would require the following:

Admin:

    First, create a set of GlusterFS volumes (no PVs yet)

User:

    Create a namespace
    Create a PVC before creating the PV
    Create Endpoints object in namespace
    Create PV pointing to the endpoints name in the namespace
    Deploy Pod

Instead we would like to suggest that the PV contain all the information needed to mount a GlusterFS volume, since PVs are available cluster wide. This way a PV would not need to point to an Endpoint, since they are only available per namespace.

Tracker for https://github.com/kubernetes/kubernetes/issues/28791

Comment 3 Luis Pabón 2016-07-25 13:50:05 UTC
Issue highlighted here: https://asciinema.org/a/80880

Comment 8 Prasanth 2016-12-16 12:57:07 UTC
Verified as fixed. 

Endpoints (and services) are now automatically created on dynamically provisioning the volumes.

Comment 9 Bhavana 2017-01-05 07:16:25 UTC
Hi Humble,

I have made minor edits to the doc text to be included in the errata. Let me know if it looks ok and sign off if you have no review comments.

Thanks

Comment 10 Humble Chirammal 2017-01-09 08:21:44 UTC
Looks good to me.

Comment 12 errata-xmlrpc 2017-01-18 21:56:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2017-0148.html


Note You need to log in before you can comment on or make changes to this bug.