Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354638 - Error downloading debug certificate
Summary: Error downloading debug certificate
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 2.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: ---
Assignee: Michael Stead
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On: 1354633
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 19:58 UTC by vritant
Modified: 2016-11-02 09:22 UTC (History)
5 users (show)

Fixed In Version: candlepin-2.0.17-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1354633
Environment:
Last Closed: 2016-11-02 09:22:49 UTC


Attachments (Terms of Use)

Description vritant 2016-07-11 19:58:03 UTC
+++ This bug was initially created as a clone of Bug #1354633 +++

A katello user reported that they were unable to download the debug certificate from the UI. The attached stack trace shows that candlepin thrown an IndexOutOfBounds exception when fetching the certificate.

A very similar issue was addressed with this BZ #1259248 but it appears that the fix has not completely addressed the issue.

It appears that candlepin is still deleting the debug certificate. More investigation is needed to determine the cause.

The version of candlepin running at the time of the exception was candlepin-0.9.54.6-1.el7.noarch.

There were no steps to reproduce provided, but the error was triggered by clicking the 'Generate and Download' button.

The workaround included in 1259248 can be used to get around the issue, but DB access is required.

Comment 1 Michael Stead 2016-08-02 16:02:35 UTC
The fix for BZ #1259248 prevents this BZ from re-occurring, but systems already affected by the bug will require some data cleanup in order to put the system back in the correct state.

The following patch will clean up the bad data via a liquibase changeset and will allow certs to be generated again. The fix will be applied once candlepin's DB upgrade script is run.

FIXED BY:
https://github.com/candlepin/candlepin/pull/1308


Note You need to log in before you can comment on or make changes to this bug.