Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354628 - ipa hostgroup-add-member does not return error message when adding itself as member
Summary: ipa hostgroup-add-member does not return error message when adding itself as ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Kaleem
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 19:24 UTC by Namita Soman
Modified: 2016-11-04 05:57 UTC (History)
4 users (show)

Fixed In Version: ipa-4.4.0-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:57:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Namita Soman 2016-07-11 19:24:06 UTC
Description of problem:

No error when adding self as member to a hostgroup

Running regressions tests for bz501377.
Error code is 1 as expected.
But error message is missing


Version-Release number of selected component (if applicable):
ipa-server-4.4.0-1.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. Add a hostgroup
# ipa hostgroup-add --desc="hostgrp1" "hostgrp1"
--------------------------
Added hostgroup "hostgrp1"
--------------------------
  Host-group: hostgrp1
  Description: hostgrp1

2. Add self as member to hostgroup
# ipa hostgroup-add-member --hostgroups="hostgrp1" hostgrp1
  Host-group: hostgrp1
  Description: hostgrp1
  Member hosts: nightcrawler.testrelm.test
  Failed members: 
-------------------------
Number of members added 0
-------------------------


Actual results:
Exit code is 1, but no error


Expected results:
Not seeing error message as was seen in 7.2
# ipa hostgroup-add-member --hostgroups="hostgrp1" hostgrp1
  Host-group: hostgrp1
  Description: hostgrp1
  Member hosts: nightcrawler.testrelm.test
  Failed members: 
    member host: 
    member host group: hostgrp1: A group may not be added as a member of itself
-------------------------
Number of members added 0
-------------------------


Additional info:

Comment 3 Petr Vobornik 2016-07-12 15:53:00 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/6026

Comment 6 Sudhir Menon 2016-08-04 11:18:47 UTC
Fix is seen.
Verified using ipa-server-4.4.0-4.el7.x86_64

[root@vm92 ~]# ipa hostgroup-add --desc="hostgrp1" "hostgrp1"
--------------------------
Added hostgroup "hostgrp1"
--------------------------
  Host-group: hostgrp1
  Description: hostgrp1
[root@vm92 ~]# ipa hostgroup-add-member --hostgroups="hostgrp1" hostgrp1
  Host-group: hostgrp1
  Description: hostgrp1
  Failed members: 
    member host: 
    member host group: hostgrp1: A group may not be added as a member of itself
-------------------------
Number of members added 0
-------------------------

Comment 8 errata-xmlrpc 2016-11-04 05:57:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.