Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354613 - pyanaconda.packaging.PayloadError: DNF error: error reading package headerTraceback (most recent call last):
Summary: pyanaconda.packaging.PayloadError: DNF error: error reading package headerTra...
Keywords:
Status: CLOSED DUPLICATE of bug 1348176
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f81ab29f15841ffd914786d8638...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 17:30 UTC by Geoffrey Marr
Modified: 2016-07-11 19:45 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-11 19:45:19 UTC


Attachments (Terms of Use)
File: anaconda-tb (deleted)
2016-07-11 17:30 UTC, Geoffrey Marr
no flags Details
File: anaconda.log (deleted)
2016-07-11 17:30 UTC, Geoffrey Marr
no flags Details
File: dnf.librepo.log (deleted)
2016-07-11 17:30 UTC, Geoffrey Marr
no flags Details
File: environ (deleted)
2016-07-11 17:30 UTC, Geoffrey Marr
no flags Details
File: hawkey.log (deleted)
2016-07-11 17:30 UTC, Geoffrey Marr
no flags Details
File: lsblk_output (deleted)
2016-07-11 17:30 UTC, Geoffrey Marr
no flags Details
File: lvm.log (deleted)
2016-07-11 17:30 UTC, Geoffrey Marr
no flags Details
File: nmcli_dev_list (deleted)
2016-07-11 17:30 UTC, Geoffrey Marr
no flags Details
File: os_info (deleted)
2016-07-11 17:30 UTC, Geoffrey Marr
no flags Details
File: storage.log (deleted)
2016-07-11 17:30 UTC, Geoffrey Marr
no flags Details
File: syslog (deleted)
2016-07-11 17:30 UTC, Geoffrey Marr
no flags Details
File: ifcfg.log (deleted)
2016-07-11 17:30 UTC, Geoffrey Marr
no flags Details
File: packaging.log (deleted)
2016-07-11 17:30 UTC, Geoffrey Marr
no flags Details
File: program.log (deleted)
2016-07-11 17:30 UTC, Geoffrey Marr
no flags Details

Description Geoffrey Marr 2016-07-11 17:30:24 UTC
Description of problem:
Attempted running the QA:Testcase install repository Hard drive variation test. Installation gets to "Preparing transaction from installation source" and then freezes.

Version-Release number of selected component:
anaconda-25.19-1

The following was filed automatically by anaconda:
anaconda 25.19-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/packaging/dnfpayload.py", line 828, in install
    raise packaging.PayloadError("DNF error: %s" % msg)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/install.py", line 241, in doInstall
    payload.install()
  File "/usr/lib64/python3.5/threading.py", line 862, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.5/site-packages/pyanaconda/threads.py", line 251, in run
    threading.Thread.run(self, *args, **kwargs)
pyanaconda.packaging.PayloadError: DNF error: error reading package headerTraceback (most recent call last):
  File "/usr/lib64/python3.5/site-packages/pyanaconda/packaging/dnfpayload.py", line 210, in do_transaction
    base.do_transaction(display=display)
  File "/usr/lib/python3.5/site-packages/dnf/base.py", line 563, in do_transaction
    self.transaction.populate_rpm_ts(self._ts)
  File "/usr/lib/python3.5/site-packages/dnf/transaction.py", line 183, in populate_rpm_ts
    hdr = tsi.installed.header
  File "/usr/lib/python3.5/site-packages/dnf/package.py", line 78, in header
    return dnf.rpm.header(self.localPkg())
  File "/usr/lib/python3.5/site-packages/dnf/rpm/__init__.py", line 58, in header
    return ts.hdrFromFdno(fdno)
  File "/usr/lib64/python3.5/site-packages/rpm/transaction.py", line 175, in hdrFromFdno
    raise rpm.error("error reading package header")
_rpm.error: error reading package header


Additional info:
addons:         com_redhat_kdump, com_redhat_docker
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img inst.stage2=hd:LABEL=Fedora-S-dvd-x86_64-rawh quiet inst.repo=hd:sdb3:/DVD.iso
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.7.0-0.rc5.git3.1.fc25.x86_64
product:        Fedora
release:        Cannot get release name.
reproducible:   Not sure how to reproduce the problem
type:           anaconda
version:        rawhide

Comment 1 Geoffrey Marr 2016-07-11 17:30:32 UTC
Created attachment 1178490 [details]
File: anaconda-tb

Comment 2 Geoffrey Marr 2016-07-11 17:30:34 UTC
Created attachment 1178491 [details]
File: anaconda.log

Comment 3 Geoffrey Marr 2016-07-11 17:30:35 UTC
Created attachment 1178492 [details]
File: dnf.librepo.log

Comment 4 Geoffrey Marr 2016-07-11 17:30:36 UTC
Created attachment 1178493 [details]
File: environ

Comment 5 Geoffrey Marr 2016-07-11 17:30:36 UTC
Created attachment 1178494 [details]
File: hawkey.log

Comment 6 Geoffrey Marr 2016-07-11 17:30:37 UTC
Created attachment 1178495 [details]
File: lsblk_output

Comment 7 Geoffrey Marr 2016-07-11 17:30:41 UTC
Created attachment 1178496 [details]
File: lvm.log

Comment 8 Geoffrey Marr 2016-07-11 17:30:42 UTC
Created attachment 1178497 [details]
File: nmcli_dev_list

Comment 9 Geoffrey Marr 2016-07-11 17:30:43 UTC
Created attachment 1178498 [details]
File: os_info

Comment 10 Geoffrey Marr 2016-07-11 17:30:45 UTC
Created attachment 1178499 [details]
File: storage.log

Comment 11 Geoffrey Marr 2016-07-11 17:30:46 UTC
Created attachment 1178500 [details]
File: syslog

Comment 12 Geoffrey Marr 2016-07-11 17:30:47 UTC
Created attachment 1178501 [details]
File: ifcfg.log

Comment 13 Geoffrey Marr 2016-07-11 17:30:48 UTC
Created attachment 1178502 [details]
File: packaging.log

Comment 14 Geoffrey Marr 2016-07-11 17:30:49 UTC
Created attachment 1178503 [details]
File: program.log

Comment 15 Igor Gnatenko 2016-07-11 19:45:19 UTC

*** This bug has been marked as a duplicate of bug 1348176 ***


Note You need to log in before you can comment on or make changes to this bug.