Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354607 - [FC23] firewalld version detection is broken
Summary: [FC23] firewalld version detection is broken
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: otopi
Classification: oVirt
Component: Plugins.network
Version: master
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.0.1
: 1.5.1
Assignee: Yedidyah Bar David
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On:
Blocks: 1306739 1491663 1491666 1503440
TreeView+ depends on / blocked
 
Reported: 2016-07-11 17:02 UTC by Yedidyah Bar David
Modified: 2017-10-18 06:45 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Rebase otopi to support firewalld version >= 0.4.3.2 Highlights, important fixes, or notable enhancements: Fixes firewalld detection with firewalld >= 0.4.3.2 shipped with Fedora >= 23
Clone Of:
: 1491663 1491666 (view as bug list)
Environment:
Last Closed: 2016-07-26 11:01:27 UTC
oVirt Team: Integration
rule-engine: ovirt-4.0.z+
rule-engine: blocker+
rule-engine: planning_ack+
sbonazzo: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 60518 master MERGED network: firewalld: Fix version check 2016-07-11 20:22:25 UTC
oVirt gerrit 60540 otopi-1.5 MERGED network: firewalld: Fix version check 2016-07-11 20:28:20 UTC

Description Yedidyah Bar David 2016-07-11 17:02:56 UTC
Description of problem:

A recent-enough version of firewalld causes otopi to not detect firewalld version, with this in the log:

2016-07-11 19:53:32 DEBUG otopi.plugins.otopi.network.firewalld firewalld._get_firewalld_cmd_version:118 Exception during firewalld dection
Traceback (most recent call last):
  File "/usr/share/otopi/plugins/otopi/network/firewalld.py", line 105, in _get_firewalld_cmd_version
    self.logger.debug('firewalld version: %s', client.VERSION)
AttributeError: 'module' object has no attribute 'VERSION'

Version-Release number of selected component (if applicable):

firewalld-0.4.3.2-1

Used to work with firewalld-0.3.9-14

How reproducible:
Always

Steps to Reproduce:
1. Run 'otopi'
2.
3.

Actual results:
See above

Expected results:
Correctly identifies version

Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2016-07-11 17:42:46 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 3 Lukas Svaty 2016-07-26 11:01:27 UTC
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA


Note You need to log in before you can comment on or make changes to this bug.