Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354605 - sna acceleration causes improper rendering
Summary: sna acceleration causes improper rendering
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 16:54 UTC by Artom Lifshitz
Modified: 2016-07-27 18:56 UTC (History)
3 users (show)

Fixed In Version: xorg-x11-drv-intel-2.99.917-24.20160712.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 18:56:03 UTC


Attachments (Terms of Use)

Description Artom Lifshitz 2016-07-11 16:54:06 UTC
Description of problem:

The default sna acceleration causes improper rendering. For example, when typing away in a mate-terminal, the typed text will only appear after a certain line width has been reached, tab completion triggered, or Enter pressed.

Version-Release number of selected component (if applicable):

2.99.917

How reproducible:

100% in a MATE+xmonad environment

Steps to Reproduce:
1. Login to a xmonad-mate session, as provided by the xmonad-mate package.
2. Open a mate-terminal window
3. Type anything

Actual results:

The typed text only appears after a certain line width has been reached, tab completion triggered, or Enter pressed.

Expected results:

The typed text appears immediately.

Additional info:

This seems to be related to BZ1093282.

Relevant lspci -vv output:

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06) (prog-if 00 [VGA controller])
	Subsystem: Lenovo Device 221e
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 29
	Region 0: Memory at b1400000 (64-bit, non-prefetchable) [size=4M]
	Region 2: Memory at a0000000 (64-bit, prefetchable) [size=256M]
	Region 4: I/O ports at 5000 [size=64]
	[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: i915
	Kernel modules: i915

Also note that switching to uxa acceleration fixes the issue. Specifically, the workaround is to create a /etc/X11/xorg.conf.d/20-intel.conf file with the following contents:

Section "Device"                                                                                                    
        Identifier  "card0"
        Driver      "intel"
        Option      "AccelMethod"  "uxa"
EndSection

Comment 1 Hans de Goede 2016-07-12 09:53:11 UTC
I've just build a new version of the intel driver which hopefully fixes this, can you please test:

http://koji.fedoraproject.org/koji/buildinfo?buildID=779664

Comment 2 Artom Lifshitz 2016-07-12 11:05:53 UTC
Can confirm 2.99.917-24.20160712.fc24.x86_64 fixes this issue for me. No more weird rendering with sna enabled.

Comment 3 Fedora Update System 2016-07-12 15:47:03 UTC
xorg-x11-drv-intel-2.99.917-24.20160712.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8aabc73dbf

Comment 4 Fedora Update System 2016-07-13 01:24:47 UTC
xorg-x11-drv-intel-2.99.917-24.20160712.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8aabc73dbf

Comment 5 Fedora Update System 2016-07-27 18:55:59 UTC
xorg-x11-drv-intel-2.99.917-24.20160712.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.