Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354602 - unittests for python-novaclient are broken
Summary: unittests for python-novaclient are broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-novaclient
Version: 5.0 (RHEL 7)
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: async
: 5.0 (RHEL 7)
Assignee: melanie witt
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks: 1358019
TreeView+ depends on / blocked
 
Reported: 2016-07-11 16:38 UTC by Michal Pryc
Modified: 2016-10-05 19:17 UTC (History)
12 users (show)

Fixed In Version: python-novaclient-2.18.0-2.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1358019 (view as bug list)
Environment:
Last Closed: 2016-10-05 19:17:14 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2019 normal SHIPPED_LIVE openstack-nova bug fix advisory 2016-10-05 23:12:34 UTC

Description Michal Pryc 2016-07-11 16:38:00 UTC
Description of problem:

While running unit tests the following errors are thrown:

[cloud-user@python-novaclient-9-1468252261-unit-tester-1 python-novaclient]$ export PBR_VERSION=0.7.0;
[cloud-user@python-novaclient-9-1468252261-unit-tester-1 python-novaclient]$ testenv=$(python -c 'import sys; print "py%i%i" % (sys.version_info[:2])');
[cloud-user@python-novaclient-9-1468252261-unit-tester-1 python-novaclient]$ truncate --size 0 requirements.txt;
[cloud-user@python-novaclient-9-1468252261-unit-tester-1 python-novaclient]$ truncate --size 0 test-requirements.txt;
[cloud-user@python-novaclient-9-1468252261-unit-tester-1 python-novaclient]$ tox --sitepackages -v -e$testenv
using tox.ini: /home/cloud-user/python-novaclient/tox.ini
using tox-1.8.1 from /usr/lib/python2.7/site-packages/tox/__init__.pyc
py27 create: /home/cloud-user/python-novaclient/.tox/py27
  /home/cloud-user/python-novaclient/.tox$ /usr/bin/python -mvirtualenv --setuptools --system-site-packages --python /usr/bin/python2.7 py27 >/home/cloud-user/python-novaclient/.tox/py27/log/py27-0.log
py27 installdeps: -r/home/cloud-user/python-novaclient/requirements.txt, -r/home/cloud-user/python-novaclient/test-requirements.txt
  /home/cloud-user/python-novaclient$ /home/cloud-user/python-novaclient/.tox/py27/bin/pip install -U -r/home/cloud-user/python-novaclient/requirements.txt -r/home/cloud-user/python-novaclient/test-requirements.txt >/home/cloud-user/python-novaclient/.tox/py27/log/py27-1.log
py27 develop-inst: /home/cloud-user/python-novaclient
  /home/cloud-user/python-novaclient$ /home/cloud-user/python-novaclient/.tox/py27/bin/pip install -U -e /home/cloud-user/python-novaclient >/home/cloud-user/python-novaclient/.tox/py27/log/py27-2.log
py27 runtests: PYTHONHASHSEED='1946143332'
py27 runtests: commands[0] | python setup.py testr --testr-args=
  /home/cloud-user/python-novaclient$ /home/cloud-user/python-novaclient/.tox/py27/bin/python setup.py testr --testr-args= 
running testr
running=OS_STDOUT_CAPTURE=${OS_STDOUT_CAPTURE:-1} OS_STDERR_CAPTURE=${OS_STDERR_CAPTURE:-1} ${PYTHON:-python} -m subunit.run discover -t ./ ./ --list 
running=OS_STDOUT_CAPTURE=${OS_STDOUT_CAPTURE:-1} OS_STDERR_CAPTURE=${OS_STDERR_CAPTURE:-1} ${PYTHON:-python} -m subunit.run discover -t ./ ./  --load-list /tmp/tmp4yh3OL
running=OS_STDOUT_CAPTURE=${OS_STDOUT_CAPTURE:-1} OS_STDERR_CAPTURE=${OS_STDERR_CAPTURE:-1} ${PYTHON:-python} -m subunit.run discover -t ./ ./  --load-list /tmp/tmpWVgVx6
running=OS_STDOUT_CAPTURE=${OS_STDOUT_CAPTURE:-1} OS_STDERR_CAPTURE=${OS_STDERR_CAPTURE:-1} ${PYTHON:-python} -m subunit.run discover -t ./ ./  --load-list /tmp/tmpPhkBQS
running=OS_STDOUT_CAPTURE=${OS_STDOUT_CAPTURE:-1} OS_STDERR_CAPTURE=${OS_STDERR_CAPTURE:-1} ${PYTHON:-python} -m subunit.run discover -t ./ ./  --load-list /tmp/tmpTMHNcP
======================================================================
FAIL: novaclient.tests.test_client.ClientTest.test_init_with_proper_connection_pool
tags: worker-0
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/mock.py", line 1201, in patched
    return func(*args, **keywargs)
  File "novaclient/tests/test_client.py", line 321, in test_init_with_proper_connection_pool
    connection_pool=True)
  File "novaclient/client.py", line 92, in __init__
    self.auth_url = auth_url.rstrip('/')
AttributeError: 'NoneType' object has no attribute 'rstrip'
Traceback (most recent call last):
_StringException: Empty attachments:
  stderr
  stdout

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/mock.py", line 1201, in patched
    return func(*args, **keywargs)
  File "novaclient/tests/test_client.py", line 321, in test_init_with_proper_connection_pool
    connection_pool=True)
  File "novaclient/client.py", line 92, in __init__
    self.auth_url = auth_url.rstrip('/')
AttributeError: 'NoneType' object has no attribute 'rstrip'

Traceback (most recent call last):
_StringException: Empty attachments:
  stderr
  stdout

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/mock.py", line 1201, in patched
    return func(*args, **keywargs)
  File "novaclient/tests/test_client.py", line 321, in test_init_with_proper_connection_pool
    connection_pool=True)
  File "novaclient/client.py", line 92, in __init__
    self.auth_url = auth_url.rstrip('/')
AttributeError: 'NoneType' object has no attribute 'rstrip'
======================================================================
FAIL: novaclient.tests.test_client.ClientTest.test_token_and_bypass_url
tags: worker-0
----------------------------------------------------------------------
Traceback (most recent call last):
  File "novaclient/tests/test_client.py", line 258, in test_token_and_bypass_url
    bypass_url="compute/v100/")
  File "novaclient/client.py", line 92, in __init__
    self.auth_url = auth_url.rstrip('/')
AttributeError: 'NoneType' object has no attribute 'rstrip'
Traceback (most recent call last):
_StringException: Empty attachments:
  stderr
  stdout

Traceback (most recent call last):
  File "novaclient/tests/test_client.py", line 258, in test_token_and_bypass_url
    bypass_url="compute/v100/")
  File "novaclient/client.py", line 92, in __init__
    self.auth_url = auth_url.rstrip('/')
AttributeError: 'NoneType' object has no attribute 'rstrip'

Traceback (most recent call last):
_StringException: Empty attachments:
  stderr
  stdout

Traceback (most recent call last):
  File "novaclient/tests/test_client.py", line 258, in test_token_and_bypass_url
    bypass_url="compute/v100/")
  File "novaclient/client.py", line 92, in __init__
    self.auth_url = auth_url.rstrip('/')
AttributeError: 'NoneType' object has no attribute 'rstrip'
======================================================================
FAIL: novaclient.tests.v1_1.test_servers.ServersTest.test_find
tags: worker-3
----------------------------------------------------------------------
Traceback (most recent call last):
  File "novaclient/tests/v1_1/test_servers.py", line 218, in test_find
    cs.assert_called('GET', '/servers', pos=-2)
  File "novaclient/tests/fakes.py", line 49, in assert_called
    (expected + called)
AssertionError: Expected GET /servers; got GET /servers?name=sample-server
Traceback (most recent call last):
_StringException: Empty attachments:
  stderr
  stdout

Traceback (most recent call last):
  File "novaclient/tests/v1_1/test_servers.py", line 218, in test_find
    cs.assert_called('GET', '/servers', pos=-2)
  File "novaclient/tests/fakes.py", line 49, in assert_called
    (expected + called)
AssertionError: Expected GET /servers; got GET /servers?name=sample-server

Traceback (most recent call last):
_StringException: Empty attachments:
  stderr
  stdout

Traceback (most recent call last):
  File "novaclient/tests/v1_1/test_servers.py", line 218, in test_find
    cs.assert_called('GET', '/servers', pos=-2)
  File "novaclient/tests/fakes.py", line 49, in assert_called
    (expected + called)
AssertionError: Expected GET /servers; got GET /servers?name=sample-server
======================================================================
FAIL: novaclient.tests.v3.test_servers.ServersTest.test_find
tags: worker-0
----------------------------------------------------------------------
Traceback (most recent call last):
  File "novaclient/tests/v3/test_servers.py", line 160, in test_find
    cs.assert_called('GET', '/servers', pos=-2)
  File "novaclient/tests/fakes.py", line 49, in assert_called
    (expected + called)
AssertionError: Expected GET /servers; got GET /servers?name=sample-server
Traceback (most recent call last):
_StringException: Empty attachments:
  stderr
  stdout

Traceback (most recent call last):
  File "novaclient/tests/v3/test_servers.py", line 160, in test_find
    cs.assert_called('GET', '/servers', pos=-2)
  File "novaclient/tests/fakes.py", line 49, in assert_called
    (expected + called)
AssertionError: Expected GET /servers; got GET /servers?name=sample-server

Traceback (most recent call last):
_StringException: Empty attachments:
  stderr
  stdout

Traceback (most recent call last):
  File "novaclient/tests/v3/test_servers.py", line 160, in test_find
    cs.assert_called('GET', '/servers', pos=-2)
  File "novaclient/tests/fakes.py", line 49, in assert_called
    (expected + called)
AssertionError: Expected GET /servers; got GET /servers?name=sample-server
Ran 776 tests in 7.935s
FAILED (id=0, failures=4)
error: testr failed (1)
ERROR: InvocationError: '/home/cloud-user/python-novaclient/.tox/py27/bin/python setup.py testr --testr-args='
____________________________________________________________________________________________ summary _____________________________________________________________________________________________
ERROR:   py27: commands failed



How reproducible:

always

Steps to Reproduce:
1. run unit tests in the python-novaclient for rhos5

Comment 6 errata-xmlrpc 2016-10-05 19:17:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2019.html


Note You need to log in before you can comment on or make changes to this bug.