Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354600 - Add pcs support for rule-based resource parameters
Summary: Add pcs support for rule-based resource parameters
Keywords:
Status: CLOSED DUPLICATE of bug 1250744
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcs
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Tomas Jelinek
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 16:33 UTC by Ken Gaillot
Modified: 2016-07-12 07:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-12 07:07:08 UTC


Attachments (Terms of Use)

Description Ken Gaillot 2016-07-11 16:33:37 UTC
Pacemaker allows resource parameters to be controlled by rules (for example, one set of parameters may be used on one node, and a different set on another node). However, pcs supports rules only for location constraints.

In the 7.4 timeframe, Pacemaker is expected to add support for versioned resource parameters, where different parameters can be used depending on the installed version of the resource agent. This will be expressed as a rule with a special '#ra-version' node attribute. So, rule-based resource parameters might become more useful and common after that.

At a minimum, pcs should support *displaying* rule-based resource parameters. Currently, if such are configured, pcs simply runs all the parameter sets together, so it looks like options are set multiple times with multiple values. For example, "pcs resource show" might display:

 Resource: test (class=ocf provider=pacemaker type=Dummy)
  Attributes: fake=foo op_sleep=3 fake=boo op_sleep=2 fake=woo op_sleep=1

where there are multiple instance_attributes sections setting fake and op_sleep based on rules. I believe "pcs constraint show" already handles rules well, so that could be used as a model.

Support for creating rules would of course be useful, too.

Upstream documentation is at http://clusterlabs.org/doc/en-US/Pacemaker/1.1-pcs/html-single/Pacemaker_Explained/index.html#_using_rules_to_control_resource_options

Comment 2 Tomas Jelinek 2016-07-12 07:07:08 UTC

*** This bug has been marked as a duplicate of bug 1250744 ***


Note You need to log in before you can comment on or make changes to this bug.