Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354598 - Can not change vxlan port number to anything other than default (4789)
Summary: Can not change vxlan port number to anything other than default (4789)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules
Version: 9.0 (Mitaka)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Jason Guiditta
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 16:21 UTC by Jason Guiditta
Modified: 2016-08-15 07:19 UTC (History)
12 users (show)

Fixed In Version: openstack-puppet-modules-8.1.5-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1352115
Environment:
Last Closed: 2016-08-15 07:19:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 340372 None None None 2016-07-11 16:21:35 UTC
Red Hat Product Errata RHEA-2016:1597 normal SHIPPED_LIVE Red Hat OpenStack Platform 9 Release Candidate Advisory 2016-08-11 16:06:52 UTC

Description Jason Guiditta 2016-07-11 16:21:36 UTC
This fix is merged upstream and already has ACKs for liberty.

+++ This bug was initially created as a clone of Bug #1352115 +++

Description of problem:Can not change vxlan port number to anything other than default (4789)

The logic seems to be wrong in the code:https://github.com/redhat-openstack/openstack-puppet-modules/blob/stable/liberty/neutron/lib/puppet/parser/functions/validate_vxlan_udp_port.rb

 i believe it should be :

if value != 4789 and (49151 >= value or value > 65535)
      raise Puppet::Error, "vxlan udp port is invalid."



How reproducible:
100%

Steps to Reproduce:
1.change vxlan port
2.note error
3.

Actual results:
error

Expected results:
ability to change default port


Additional info:

--- Additional comment from Assaf Muller on 2016-07-01 12:34:29 EDT ---

Reassigning to the openstack neutron puppet modules.

--- Additional comment from David Hill on 2016-07-04 14:29:11 EDT ---

I believe this check should be removed unless we really can't assign vxlan ports on the higher port and keep only the > 65535 and add = 0 ...

--- Additional comment from Jeremy on 2016-07-05 09:27:59 EDT ---

Current package levels:
[root heat-admin]# rpm -qa |grep neutron
openstack-neutron-common-7.0.1-15.el7ost.noarch
openstack-neutron-bigswitch-lldp-2015.3.8-1.el7ost.noarch
python-neutron-lbaas-7.0.0-2.el7ost.noarch
openstack-neutron-7.0.1-15.el7ost.noarch
openstack-neutron-openvswitch-7.0.1-15.el7ost.noarch
openstack-neutron-metering-agent-7.0.1-15.el7ost.noarch
python-neutron-7.0.1-15.el7ost.noarch
openstack-neutron-bigswitch-agent-2015.3.8-1.el7ost.noarch
openstack-neutron-lbaas-7.0.0-2.el7ost.noarch
openstack-neutron-ml2-7.0.1-15.el7ost.noarch
python-neutronclient-3.1.0-1.el7ost.noarch

Comment 1 Jason Guiditta 2016-07-11 16:22:44 UTC
Merged upstream

Comment 3 Alexander Stafeyev 2016-08-04 11:50:23 UTC
Applying 192.168.1.17_neutron.pp
192.168.1.17_neutron.pp:                          [ ERROR ]        
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 192.168.1.17_neutron.pp
Error: vxlan udp port is invalid. on node controller.novalocal

Changed the port to 49151 

[root@controller ~]# rpm -qa | grep pup
openstack-packstack-puppet-8.0.0-4.el7ost.noarch
puppet-3.6.2-2.el7.noarch
openstack-puppet-modules-8.1.7-1.el7ost.noarch

Comment 4 Jason Guiditta 2016-08-04 12:53:08 UTC
(In reply to Alexander Stafeyev from comment #3)
> Applying 192.168.1.17_neutron.pp
> 192.168.1.17_neutron.pp:                          [ ERROR ]        
> Applying Puppet manifests                         [ ERROR ]
> 
> ERROR : Error appeared during Puppet run: 192.168.1.17_neutron.pp
> Error: vxlan udp port is invalid. on node controller.novalocal
> 
> Changed the port to 49151 
> 
> [root@controller ~]# rpm -qa | grep pup
> openstack-packstack-puppet-8.0.0-4.el7ost.noarch
> puppet-3.6.2-2.el7.noarch
> openstack-puppet-modules-8.1.7-1.el7ost.noarch

It looks to me from the patch:
https://review.openstack.org/#/c/340372/1/lib/puppet/parser/functions/validate_vxlan_udp_port.rb

That 49151 is indeed invalid, I think you are supposed to be able to specific a port from 49152 to 65535 inclusive. Can you retest with a value in that range please?

Comment 5 Alexander Stafeyev 2016-08-07 02:58:19 UTC
Configured port to 49152 and the installation passed well

Finalizing                                           [ DONE ]

 **** Installation completed successfully ******




[root@controller ~]# rpm -qa | grep puppet
openstack-packstack-puppet-8.0.0-4.el7ost.noarch
puppet-3.6.2-2.el7.noarch
openstack-puppet-modules-8.1.7-1.el7ost.noarch

Comment 7 errata-xmlrpc 2016-08-15 07:19:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-1597.html


Note You need to log in before you can comment on or make changes to this bug.