Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354590 - program crash
Summary: program crash
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: kdepim
Version: 24
Hardware: i386
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 16:09 UTC by Claude Frantz
Modified: 2017-08-08 15:31 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-08 15:31:22 UTC


Attachments (Terms of Use)
valgrind's log when ending in the reported situation (deleted)
2016-07-11 16:09 UTC, Claude Frantz
no flags Details
gdb output when aconadinconsole is crashing (deleted)
2016-07-13 17:12 UTC, Claude Frantz
no flags Details
The output as requested by Rex (deleted)
2016-07-13 17:36 UTC, Claude Frantz
no flags Details
the gdb output after crash, then "thread apply all bt" (deleted)
2016-07-14 05:56 UTC, Claude Frantz
no flags Details
with debuginfo installed (deleted)
2016-07-14 13:51 UTC, Claude Frantz
no flags Details
The error window (deleted)
2016-07-14 17:42 UTC, Claude Frantz
no flags Details
The output at the terminal window (deleted)
2016-07-15 06:16 UTC, Claude Frantz
no flags Details
The valgrind log output (deleted)
2016-07-15 06:17 UTC, Claude Frantz
no flags Details
gdb output (deleted)
2016-07-20 06:48 UTC, Claude Frantz
no flags Details
akonadiconsole: gdb output after crash (deleted)
2016-07-20 08:50 UTC, Claude Frantz
no flags Details

Description Claude Frantz 2016-07-11 16:09:39 UTC
Created attachment 1178466 [details]
valgrind's log when ending in the reported situation

Description of problem:
korganizer crashes when entering: Settings -> Config -> Korganizer

Version-Release number of selected component (if applicable):
korganizer-16.04.2-2.fc24.i686

How reproducible:
Always

Steps to Reproduce:
1. Settings
2. Config
3. Korganizer

Actual results:
crash


Expected results:
hi hi

Additional info:
valgrind output

Comment 1 Claude Frantz 2016-07-13 14:03:52 UTC
The reported crash occurs in many circumstances when using kontact, korganisator, etc. I can see the contents of calendars but when I try to create an entry, the system crashes. The same occurs when operating on contacts.

Since the migration from F22 to F24, all the pim system is not more operational.

I have tried "akonadictl fsck" and "akonadictl vacuum", but nothing has changed.

Comment 2 Claude Frantz 2016-07-13 17:12:52 UTC
Created attachment 1179345 [details]
gdb output when aconadinconsole is crashing

Comment 3 Rex Dieter 2016-07-13 17:17:20 UTC
At the end of gdb (after crash), we need a backtrace, issue command: thread apply all bt
and post the output

If possible, reporting this to bugs.kde.org would be preferable, more eyes of the people directly working on this.

Comment 4 Claude Frantz 2016-07-13 17:36:19 UTC
Created attachment 1179346 [details]
The output as requested by Rex

Comment 5 Rex Dieter 2016-07-13 18:07:42 UTC
No, at the end *after* the crash, get the backtrace.

Comment 6 Rex Dieter 2016-07-13 18:08:27 UTC
ie, "run" first, crash, then "thread apply all bt"

Comment 7 Claude Frantz 2016-07-14 05:56:57 UTC
Created attachment 1179597 [details]
the gdb output after crash, then "thread apply all bt"

As requested by Rex.

Comment 8 Rex Dieter 2016-07-14 12:06:29 UTC
Did it crash there?  I don't see any (the backtrace is again useless, all 
#0  0xffffffff in #1  0xffffffff in #2  0xffffffff in #3  0xffffffff in #4  0xffffffff in #5  0xffffffff in #6  0xffffffff in #7  0xffffffff in #8  0xffffffff in #9  0xffffffff in #10 0xffffffff in 
Thread 14 (Thread 0xa3142b40 (LWP 6244)):

(and install the korganizer-debuginfo as suggested by gdb too to get a better backtrace).

Comment 9 Claude Frantz 2016-07-14 13:51:55 UTC
Created attachment 1179864 [details]
with debuginfo installed

There are many debug information warnings and no really useful output. What can I do now ?

Comment 10 Rex Dieter 2016-07-14 13:54:59 UTC
I have to ask again (since it was unanswered from comment #8), I don't see any crash there.  Are you running it and waiting for the crash first?  (you need to do that before getting a backtrace).

Comment 11 Rex Dieter 2016-07-14 13:58:41 UTC
and again, hint, any backtrace that includes stuff like
#0  0xffffffff in #1  0xffffffff in #2  0xffffffff in 
is not helpful, so no point in posting more like that either, sorry.

Comment 12 Claude Frantz 2016-07-14 16:08:14 UTC
I did:

-) starting korganizer while akonadi was running 
-) pressing in sequence: settings -> configure korganizer 
-) now the crash occurs and the error windows appears
-) I press debugging in gdb
-) at the (gdb) I enter "thread apply all bt"
-) the output is as I have posted

Where is my error ?

Comment 13 Rex Dieter 2016-07-14 16:25:38 UTC
ok, then these backtraces are simply not helpful in diagnosing the crash :(

Comment 14 Rex Dieter 2016-07-14 16:26:27 UTC
On the other hand, "now the crash occurs and the error windows appears"... what is in this error window precisely?

Comment 15 Claude Frantz 2016-07-14 17:42:45 UTC
Created attachment 1179916 [details]
The error window

Here you see this error window.

Comment 16 Rex Dieter 2016-07-14 17:46:41 UTC
That's the drkonqi crash handler, did you try following the "Report bug" button?

Comment 17 Claude Frantz 2016-07-14 18:22:04 UTC
Yes, I have tried it, but the program has refused to report the bug because there is to few information to report. In fact, that is the same as you have mentioned yourself, Rex.

Comment 18 Claude Frantz 2016-07-15 06:16:19 UTC
Created attachment 1180043 [details]
The output at the terminal window

As a further attempt to get more information, I have run korganizer again under valgrind and I have performed the same steps in korganizer as mentioned before.  You will find attached, the terminal output and the log generated by valgrind.

Comment 19 Claude Frantz 2016-07-15 06:17:22 UTC
Created attachment 1180044 [details]
The valgrind log output

Comment 20 Claude Frantz 2016-07-20 06:48:00 UTC
Created attachment 1181924 [details]
gdb output

This is another gdb output showing where the SIGSEGV occurs. I confess that I'm not an expert using gdb. But now, there is more information available.

Comment 21 Claude Frantz 2016-07-20 08:50:16 UTC
Created attachment 1181967 [details]
akonadiconsole: gdb output after crash

In addition, I allow me to report the crash always occurring in akonadiconsole, when pressing the "Brower" button.

Comment 22 Rex Dieter 2016-07-20 11:22:07 UTC
Truncated backtrace inline for easier viewing:

Thread 1 "akonadiconsole" received signal SIGSEGV, Segmentation fault.
0xb69e2a96 in Akonadi::Tag::id (this=0xb4f1a950 <QArrayData::shared_null+16>)
    at /usr/src/debug/akonadi-16.04.3/src/core/tag.cpp:176
176	    return d_ptr->id;
Missing separate debuginfos, use: ...
#0  0xb69e2a96 in Akonadi::Tag::id (
    this=0xb4f1a950 <QArrayData::shared_null+16>)
    at /usr/src/debug/akonadi-16.04.3/src/core/tag.cpp:176
#1  0xb6a9dacf in Akonadi::TagModel::rowCount (this=<optimized out>, 
    parent=...)
    at /usr/src/debug/akonadi-16.04.3/src/core/models/tagmodel.cpp:65
#2  0xb4dea6bd in QAbstractItemModel::hasChildren (this=0x80361360, parent=...)
    at itemmodels/qabstractitemmodel.cpp:1699
#3  0xb5af0aea in QTreeViewPrivate::hasVisibleChildren (this=this@entry=
    0x8035f800, parent=...) at itemviews/qtreeview.cpp:3909
#4  0xb5af2708 in QTreeViewPrivate::layout (this=this@entry=0x8035f800, 
    i=i@entry=-1, recursiveExpanding=recursiveExpanding@entry=false, 
    afterIsUninitialized=<optimized out>, afterIsUninitialized@entry=false)
    at itemviews/qtreeview.cpp:3388
#5  0xb5af8bcc in QTreeView::doItemsLayout (this=0x802b3108)
    at itemviews/qtreeview.cpp:2126
#6  0xb5aefce6 in QAbstractItemViewPrivate::executePostedLayout (
    this=0x8035f800) at ../../src/widgets/itemviews/qabstractitemview_p.h:228

Comment 23 Fedora End Of Life 2017-07-25 21:44:15 UTC
This message is a reminder that Fedora 24 is nearing its end of life.
Approximately 2 (two) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 24. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '24'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 24 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 24 Fedora End Of Life 2017-08-08 15:31:22 UTC
Fedora 24 changed to end-of-life (EOL) status on 2017-08-08. Fedora 24 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.