Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354572 - Remove the view_params permission in favor of edit_params
Summary: Remove the view_params permission in favor of edit_params
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Users & Roles
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Renzo Nuccitelli
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 15:27 UTC by Ivan Necas
Modified: 2019-04-01 20:27 UTC (History)
5 users (show)

Fixed In Version: foreman-1.11.0.46-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 11:21:14 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ivan Necas 2016-07-11 15:27:40 UTC
Description of problem:
The view_params permission was used in taxonomies to determine if the params in the taxonomy will be visible, The permissions is not used anywhere else. Therefore we should use the edit_params permissions to fix the params in taxonomies.

Version-Release number of selected component (if applicable):
6.2 beta 2

How reproducible:
always

Steps to Reproduce:
1. have non-admin user with edit_params permission
2. go to organization details


Actual results:
parameters tab missing

Expected results:
parameters tab is there and user is able to edit the params

Additional info:

Comment 4 Renzo Nuccitelli 2016-07-13 19:39:12 UTC
I could not reproduce the bug. What I've done:

1.Create a Role in Administer -> Roles
2.On Role creation set Resource type to Parameters
3.On Role creation add permission edit_params
4.On Role creation set Resource type to Organization
5.On Role creation add permissions edit_organizations and
view_organizations
6.Create a non admin user in Administer -> Users
7.Add previous role to this user
8.Login with previous user credentials
9.Go to Organization -> Manage Organizations
10.Choose Default Organization
11.Assert "Parameters" tab is present

I have also removed the edit_params permission and asserted "Parameters" tab was not visible anymore.

Comment 5 Renzo Nuccitelli 2016-07-13 19:41:29 UTC
(In reply to Renzo Nuccitelli from comment #4)
> I could not reproduce the bug. What I've done:
> 
> 1.Create a Role in Administer -> Roles
> 2.On Role creation set Resource type to Parameters
> 3.On Role creation add permission edit_params
> 4.On Role creation set Resource type to Organization
> 5.On Role creation add permissions edit_organizations and
> view_organizations
> 6.Create a non admin user in Administer -> Users
> 7.Add previous role to this user
> 8.Login with previous user credentials
> 9.Go to Organization -> Manage Organizations
> 10.Choose Default Organization
> 11.Assert "Parameters" tab is present
> 
> I have also removed the edit_params permission and asserted "Parameters" tab
> was not visible anymore.

In time, running rpm -q satellite I got the version:
satellite-6.2.0-20.0.el7sat.noarch

Comment 6 Bryan Kearney 2016-07-27 11:21:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.