Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354569 - Admin portal password is not cleared on timeout or "Sign out."
Summary: Admin portal password is not cleared on timeout or "Sign out."
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.0.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.0.2
: ---
Assignee: Ravi Nori
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 15:21 UTC by Bill Sanford
Modified: 2016-07-21 19:03 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-20 09:54:09 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)

Description Bill Sanford 2016-07-11 15:21:28 UTC
Description of problem: After you have logged into the Admin Portal and it stays dormant for the timeout period, it exits back into the login portion of the Admin portal. Even If I "Sign out" from the Admin portal, the password is still available for anyone to launch.

The password, at this time, should be cleared and it isn't. Anyone that is present can log into the Admin Portal without knowing the password (That is currently present) .


Version-Release number of selected component (if applicable):
rhevm-4.0.2-0.2.rc1.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Yaniv Kaul 2016-07-12 09:42:00 UTC
Isn't it the browser saving it for you?

Comment 2 Martin Perina 2016-07-12 09:58:48 UTC
(In reply to Yaniv Kaul from comment #1)
> Isn't it the browser saving it for you?

I just verified that in both cases (logout or session expired) username and password fields are empty when you are redirected to login screen. So the only way how to preserve those values in login screen is using browser feature to store login/password, which is correct behaviour (see BZ1164300 and BZ1164302).

Comment 3 Yaniv Kaul 2016-07-14 12:00:35 UTC
Removing 'security' keyword until NEEDINFO is responded.

Comment 4 Martin Perina 2016-07-20 09:54:09 UTC
According to BZ1355670 username/password was saved due to browser setting, which is a feature and not a bug.


Note You need to log in before you can comment on or make changes to this bug.