Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1354567 - OSP 8 Upgrade from OSP 7 Missing Documentation Details
Summary: OSP 8 Upgrade from OSP 7 Missing Documentation Details
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 8.0 (Liberty)
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ga
: 9.0 (Mitaka)
Assignee: Dan Macpherson
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-07-11 15:04 UTC by Benjamin Schmaus
Modified: 2016-08-29 02:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-29 02:59:11 UTC


Attachments (Terms of Use)

Description Benjamin Schmaus 2016-07-11 15:04:42 UTC
Description of problem:

When a customer is going to upgrade from OSP 7 to OSP 8, the upgrade documentation seems to be missing a couple important steps that consulting in the field has found are required:

1) Documentation does not discuss comparing your new templates with your old templates, as the previous upgrade guide did.

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/Director_Installation_and_Usage/sect-Updating_the_Overcloud.html#sect-Updating_Overcloud_Stack

2) The overcloud nodes need to be subscribed to the OSP director channel in RHN/Sat, but documentation does not reference this.


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 Dan Macpherson 2016-07-11 15:36:42 UTC
Hi Ben,

Thanks for submitting this rquest. 1) should be fine, but 2) I'm not so sure about. See below....

(In reply to Benjamin Schmaus from comment #0)
> Description of problem:
> 
> When a customer is going to upgrade from OSP 7 to OSP 8, the upgrade
> documentation seems to be missing a couple important steps that consulting
> in the field has found are required:
> 
> 1) Documentation does not discuss comparing your new templates with your old
> templates, as the previous upgrade guide did.
> 
> https://access.redhat.com/documentation/en-US/
> Red_Hat_Enterprise_Linux_OpenStack_Platform/7/html/
> Director_Installation_and_Usage/sect-Updating_the_Overcloud.html#sect-
> Updating_Overcloud_Stack

It should be fine to include a note in the upgrade progress. However, I think we're trying to dissuade customers from creating copies of the Heat template collection and instead use environment files to modify configuration, and that's soemthing we also need to make clear.

> 2) The overcloud nodes need to be subscribed to the OSP director channel in
> RHN/Sat, but documentation does not reference this.

I'm not sure I understand why we're including this repo. What's the rationale for including the director repository? My understanding is that the director repo is Undercloud only.

Comment 4 Benjamin Schmaus 2016-07-14 12:17:08 UTC
@Dan with regards to #2, it seems os-net-config is only in the director channel and that package needs to be updated on overcloud nodes as well:

[root@ospvd ~]# yum provides os-net-config
Loaded plugins: product-id, search-disabled-repos, subscription-manager
os-net-config-0.2.2-1.el7ost.noarch : Host network configuration tool
Repo        : rhel-7-server-openstack-8-director-rpms



os-net-config-0.2.3-2.el7ost.noarch : Host network configuration tool
Repo        : rhel-7-server-openstack-8-director-rpms



os-net-config-0.2.3-2.el7ost.noarch : Host network configuration tool
Repo        : @rhel-7-server-openstack-8-director-rpms

Comment 5 Dan Macpherson 2016-07-18 13:37:17 UTC
Gotcha. Thanks, Ben! I'll include that with the update.


Note You need to log in before you can comment on or make changes to this bug.